/usr/src/gcc-4.6/debian/patches/pr43804.diff is in gcc-4.6-source 4.6.3-14.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | # DP: Fix for PR target/43804 backported from SVN
2011-04-24 Richard Sandiford <richard.sandiford@linaro.org>
PR target/43804
* config/m68k/constraints.md (T): Allow PIC operands that satisfy
LEGITIMATE_PIC_OPERAND_P.
--- a/src/gcc/config/m68k/constraints.md
+++ b/src/gcc/config/m68k/constraints.md
@@ -94,7 +94,8 @@
(define_constraint "T"
"Used for operands that satisfy 's' when -mpcrel is not in effect."
(and (match_code "symbol_ref,label_ref,const")
- (match_test "!flag_pic")))
+ (match_test "!TARGET_PCREL")
+ (match_test "!flag_pic || LEGITIMATE_PIC_OPERAND_P (op)")))
(define_memory_constraint "Q"
"Means address register indirect addressing mode."
|