/usr/src/gcc-4.7/debian/patches/ada-mips.diff is in gcc-4.7-source 4.7.2-5.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 | # DP: Improve support for mips.
--- a/src/gcc/ada/gcc-interface/Makefile.in
+++ b/src/gcc/ada/gcc-interface/Makefile.in
@@ -1666,7 +1666,7 @@
s-taprop.adb<s-taprop-linux.adb \
s-tasinf.ads<s-tasinf-linux.ads \
s-tasinf.adb<s-tasinf-linux.adb \
- s-taspri.ads<s-taspri-posix.ads \
+ s-taspri.ads<s-taspri-posix-noaltstack.ads \
s-tpopsp.adb<s-tpopsp-posix-foreign.adb \
system.ads<system-linux-mips.ads
@@ -1690,6 +1690,11 @@
s-tpopsp.adb<s-tpopsp-posix-foreign.adb \
system.ads<system-linux-mips.ads
+ TOOLS_TARGET_PAIRS = \
+ mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb \
+ indepsw.adb<indepsw-gnu.adb
+
+ EXTRA_GNATRTL_TASKING_OBJS=s-linux.o
EH_MECHANISM=-gcc
THREADSLIB = -lpthread
GNATLIB_SHARED = gnatlib-shared-dual
--- a/src/config/bootstrap-debug.mk
+++ b/src/config/bootstrap-debug.mk
@@ -9,4 +9,5 @@
# For more thorough testing, see bootstrap-debug-lean.mk
STAGE2_CFLAGS += -gtoggle
+STAGE3_CFLAGS += -gtoggle
do-compare = $(SHELL) $(srcdir)/contrib/compare-debug $$f1 $$f2
|