/usr/src/gcc-5/debian/patches/ada-gcc-name.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 | # DP: use gcc-5 instead of gcc as the command name.
Index: b/src/gcc/ada/gnatlink.adb
===================================================================
--- a/src/gcc/ada/gnatlink.adb
+++ b/src/gcc/ada/gnatlink.adb
@@ -136,7 +136,7 @@ procedure Gnatlink is
-- This table collects the arguments to be passed to compile the binder
-- generated file.
- Gcc : String_Access := Program_Name ("gcc", "gnatlink");
+ Gcc : String_Access := Program_Name ("gcc-5", "gnatlink");
Read_Mode : constant String := "r" & ASCII.NUL;
@@ -1412,7 +1412,8 @@ procedure Gnatlink is
end if;
Write_Line (" --GCC=comp Use comp as the compiler");
- Write_Line (" --LINK=nam Use 'nam' for the linking rather than 'gcc'");
+ Write_Line (" --LINK=nam Use 'nam' for the linking rather " &
+ "than 'gcc-5'");
Write_Eol;
Write_Line (" [non-Ada-objects] list of non Ada object files");
Write_Line (" [linker-options] other options for the linker");
Index: b/src/gcc/ada/make.adb
===================================================================
--- a/src/gcc/ada/make.adb
+++ b/src/gcc/ada/make.adb
@@ -671,14 +671,14 @@ package body Make is
-- Compiler, Binder & Linker Data and Subprograms --
----------------------------------------------------
- Gcc : String_Access := Program_Name ("gcc", "gnatmake");
+ Gcc : String_Access := Program_Name ("gcc-5", "gnatmake");
Original_Gcc : constant String_Access := Gcc;
-- Original_Gcc is used to check if Gcc has been modified by a switch
-- --GCC=, so that for VM platforms, it is not modified again, as it can
-- result in incorrect error messages if the compiler cannot be found.
- Gnatbind : String_Access := Program_Name ("gnatbind", "gnatmake");
- Gnatlink : String_Access := Program_Name ("gnatlink", "gnatmake");
+ Gnatbind : String_Access := Program_Name ("gnatbind-5", "gnatmake");
+ Gnatlink : String_Access := Program_Name ("gnatlink-5", "gnatmake");
-- Default compiler, binder, linker programs
Globalizer : constant String := "codepeer_globalizer";
Index: b/src/gcc/ada/gnatchop.adb
===================================================================
--- a/src/gcc/ada/gnatchop.adb
+++ b/src/gcc/ada/gnatchop.adb
@@ -44,7 +44,7 @@ procedure Gnatchop is
Config_File_Name : constant String_Access := new String'("gnat.adc");
-- The name of the file holding the GNAT configuration pragmas
- Gcc : String_Access := new String'("gcc");
+ Gcc : String_Access := new String'("gcc-5");
-- May be modified by switch --GCC=
Gcc_Set : Boolean := False;
Index: b/src/gcc/ada/mdll-utl.adb
===================================================================
--- a/src/gcc/ada/mdll-utl.adb
+++ b/src/gcc/ada/mdll-utl.adb
@@ -39,7 +39,7 @@ package body MDLL.Utl is
Dlltool_Name : constant String := "dlltool";
Dlltool_Exec : OS_Lib.String_Access;
- Gcc_Name : constant String := "gcc";
+ Gcc_Name : constant String := "gcc-5";
Gcc_Exec : OS_Lib.String_Access;
Gnatbind_Name : constant String := "gnatbind";
@@ -212,7 +212,7 @@ package body MDLL.Utl is
end;
end if;
- Print_Command ("gcc", Arguments (1 .. A));
+ Print_Command ("gcc-5", Arguments (1 .. A));
OS_Lib.Spawn (Gcc_Exec.all, Arguments (1 .. A), Success);
Index: b/src/gcc/ada/mlib-utl.adb
===================================================================
--- a/src/gcc/ada/mlib-utl.adb
+++ b/src/gcc/ada/mlib-utl.adb
@@ -446,7 +446,7 @@ package body MLib.Utl is
if Driver_Name = No_Name then
if Gcc_Exec = null then
if Gcc_Name = null then
- Gcc_Name := Osint.Program_Name ("gcc", "gnatmake");
+ Gcc_Name := Osint.Program_Name ("gcc-5", "gnatmake");
end if;
Gcc_Exec := Locate_Exec_On_Path (Gcc_Name.all);
Index: b/src/gcc/ada/prj-makr.adb
===================================================================
--- a/src/gcc/ada/prj-makr.adb
+++ b/src/gcc/ada/prj-makr.adb
@@ -115,7 +115,7 @@ package body Prj.Makr is
procedure Dup2 (Old_Fd, New_Fd : File_Descriptor);
- Gcc : constant String := "gcc";
+ Gcc : constant String := "gcc-5";
Gcc_Path : String_Access := null;
Non_Empty_Node : constant Project_Node_Id := 1;
|