/usr/src/gcc-5/debian/patches/gdc-base-version.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 | # DP: Use the GCC base version for the D include dir name
Index: b/src/libphobos/m4/druntime.m4
===================================================================
--- a/src/libphobos/m4/druntime.m4
+++ b/src/libphobos/m4/druntime.m4
@@ -43,7 +43,7 @@ AC_DEFUN([DRUNTIME_INSTALL_DIRECTORIES],
AC_REQUIRE([AC_PROG_GDC])
AC_MSG_CHECKING([D GCC version])
- d_gcc_ver=`$GDC -dumpversion`
+ d_gcc_ver=`$GDC -dumpversion | sed 's/^\(@<:@0-9@:>@*\).*/\1/'`
AC_MSG_RESULT($d_gcc_ver)
AC_ARG_WITH([cross-host],
AC_HELP_STRING([--with-cross-host=HOST],
Index: b/src/libphobos/configure.ac
===================================================================
--- a/src/libphobos/configure.ac
+++ b/src/libphobos/configure.ac
@@ -53,6 +53,7 @@ m4_rename([_AC_ARG_VAR_PRECIOUS],[glibd_
m4_define([_AC_ARG_VAR_PRECIOUS],[])
AM_PROG_AS
AC_PROG_CC
+dnl dummy change to run autoreconf in this directory
AC_PROG_GDC
WITH_LOCAL_DRUNTIME([GDC_CHECK_COMPILE], [])
|