/usr/src/gcc-5/debian/patches/gdc-driver-nophobos.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 | # DP: Modify gdc driver to have no libphobos by default.
Index: b/src/gcc/d/d-lang.cc
===================================================================
--- a/src/gcc/d/d-lang.cc
+++ b/src/gcc/d/d-lang.cc
@@ -179,7 +179,7 @@ static void
d_init_options_struct(gcc_options *opts)
{
// GCC options
- opts->x_flag_exceptions = 1;
+ opts->x_flag_exceptions = 0;
// Avoid range issues for complex multiply and divide.
opts->x_flag_complex_method = 2;
Index: b/src/gcc/d/d-spec.c
===================================================================
--- a/src/gcc/d/d-spec.c
+++ b/src/gcc/d/d-spec.c
@@ -91,7 +91,7 @@ lang_specific_driver (cl_decoded_option
/* If nonzero, use the standard D runtime library when linking with
standard libraries. */
- int phobos = 1;
+ int phobos = 0;
/* The number of arguments being added to what's in argv, other than
libraries. We use this to track the number of times we've inserted
|