/usr/src/gcc-5/debian/patches/pr61106.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 | # DP: Proposed patch for PR driver/61106
--- a/src/gcc/optc-gen.awk
+++ b/src/gcc/optc-gen.awk
@@ -404,15 +404,17 @@ for (i = 0; i < n_enabledby; i++) {
for (j = 1; j < n_enables; j++) {
opt_var_name = var_name(flags[opt_numbers[thisenable[j]]]);
if (opt_var_name != "") {
condition = "!opts_set->x_" opt_var_name
if (thisenableif[j] != "") {
- condition = condition " && (" thisenableif[j] ")"
+ value = "(" thisenableif[j] ")"
+ } else {
+ value = "value"
}
print " if (" condition ")"
print " handle_generated_option (opts, opts_set,"
- print " " opt_enum(thisenable[j]) ", NULL, value,"
+ print " " opt_enum(thisenable[j]) ", NULL, " value ","
print " lang_mask, kind, loc, handlers, dc);"
} else {
print "#error " thisenable[j] " does not have a Var() flag"
}
}
|