/usr/src/gcc-5/debian/patches/pr61126.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 | Index: gcc/fortran/lang.opt
===================================================================
--- a/src/gcc/fortran/lang.opt (revision 210277)
+++ b/src/gcc/fortran/lang.opt (working copy)
@@ -301,6 +301,10 @@
Fortran Warning
Warn about unused dummy arguments.
+Wunused-parameter
+LangEnabledBy(Fortran,Wextra)
+; Documented in common.opt
+
Wzerotrip
Fortran Warning
Warn about zero-trip DO loops
Index: gcc/fortran/options.c
===================================================================
--- a/src/gcc/fortran/options.c (revision 210277)
+++ b/src/gcc/fortran/options.c (working copy)
@@ -674,12 +674,7 @@
break;
case OPT_Wextra:
- handle_generated_option (&global_options, &global_options_set,
- OPT_Wunused_parameter, NULL, value,
- gfc_option_lang_mask (), kind, loc,
- handlers, global_dc);
set_Wextra (value);
-
break;
case OPT_Wfunction_elimination:
Index: gcc/opts-global.c
===================================================================
--- a/src/gcc/opts-global.c (revision 210277)
+++ b/src/gcc/opts-global.c (working copy)
@@ -273,10 +273,10 @@
handlers->unknown_option_callback = unknown_option_callback;
handlers->wrong_lang_callback = complain_wrong_lang;
handlers->num_handlers = 3;
- handlers->handlers[0].handler = lang_handle_option;
- handlers->handlers[0].mask = initial_lang_mask;
- handlers->handlers[1].handler = common_handle_option;
- handlers->handlers[1].mask = CL_COMMON;
+ handlers->handlers[0].handler = common_handle_option;
+ handlers->handlers[0].mask = CL_COMMON;
+ handlers->handlers[1].handler = lang_handle_option;
+ handlers->handlers[1].mask = initial_lang_mask;
handlers->handlers[2].handler = target_handle_option;
handlers->handlers[2].mask = CL_TARGET;
}
|