/usr/src/gcc-5/debian/patches/testsuite-glibc-warnings.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 | # DP: fix testcases that triggered -Wunused-result with glibc
# DP: Author: Steve Beattie <steve.beattie@canonical.com>
---
src/gcc/testsuite/c-c++-common/cilk-plus/AN/comma_exp.c | 2 +-
src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
Index: b/src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c
===================================================================
--- a/src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c
+++ b/src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c
@@ -1,5 +1,5 @@
/* { dg-shouldfail "tsan" } */
-/* { dg-additional-options "-ldl" } */
+/* { dg-additional-options "-Wno-unused-result -ldl" } */
#include <pthread.h>
#include <unistd.h>
Index: b/src/gcc/testsuite/c-c++-common/cilk-plus/AN/comma_exp.c
===================================================================
--- a/src/gcc/testsuite/c-c++-common/cilk-plus/AN/comma_exp.c
+++ b/src/gcc/testsuite/c-c++-common/cilk-plus/AN/comma_exp.c
@@ -1,5 +1,5 @@
/* { dg-do run } */
-/* { dg-options "-fcilkplus" } */
+/* { dg-options "-fcilkplus -Wno-unused-result" } */
#include <stdlib.h>
|