/usr/src/gcc-5/debian/patches/thunderx2t99-scheduler.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 | Description: Add scheduler for Thunderx2t99
* config/aarch64/aarch64-cores.def: Change the scheduler
to Thunderx2t99.
* config/aarch64/aarch64.md: Include thunderx2t99.md.
* config/aarch64/thunderx2t99.md: New file.
.
Backported to gcc-5 by dann frazier <dannf@ubuntu.com>
Author: Julian Brown <julian@codesourcery.com>
Author: Naveen H.S <Naveen.Hurugalawadi@cavium.com>
Author: Virendra Pathak <virendra.pathak@broadcom.com>
Origin: https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=245203
Bug-Ubuntu: https://bugs.launchpad.net/bugs/1727540
Applied-Upstream: svn://gcc.gnu.org/svn/gcc/trunk@245203
--- a/src/gcc/config/aarch64/aarch64-cores.def 2017-10-20 17:19:39.650846958 -0400
+++ b/src/gcc/config/aarch64/aarch64-cores.def 2017-10-20 18:10:47.523130202 -0400
@@ -51,8 +51,8 @@ AARCH64_CORE("xgene1", xgene1, x
/* V8.1 Architecture Processors. */
-AARCH64_CORE("thunderx2t99", thunderx2t99, cortexa57, 8_1A, AARCH64_FL_FOR_ARCH8_1 | AARCH64_FL_CRYPTO, thunderx2t99, "0x42", "0x516")
-AARCH64_CORE("vulcan", vulcan, cortexa57, 8_1A, AARCH64_FL_FOR_ARCH8_1 | AARCH64_FL_CRYPTO, thunderx2t99, "0x42", "0x516")
+AARCH64_CORE("thunderx2t99", thunderx2t99, thunderx2t99, 8_1A, AARCH64_FL_FOR_ARCH8_1 | AARCH64_FL_CRYPTO, thunderx2t99, "0x42", "0x516")
+AARCH64_CORE("vulcan", vulcan, thunderx2t99, 8_1A, AARCH64_FL_FOR_ARCH8_1 | AARCH64_FL_CRYPTO, thunderx2t99, "0x42", "0x516")
/* V8 big.LITTLE implementations. */
diff -urpN a/src/gcc/config/aarch64/aarch64.md b/src/gcc/config/aarch64/aarch64.md
--- a/src/gcc/config/aarch64/aarch64.md 2017-10-20 17:04:34.804898636 -0400
+++ b/src/gcc/config/aarch64/aarch64.md 2017-10-20 18:11:08.241347156 -0400
@@ -208,6 +208,7 @@
(include "../arm/cortex-a57.md")
(include "thunderx.md")
(include "../arm/xgene1.md")
+(include "thunderx2t99.md")
;; -------------------------------------------------------------------
;; Jumps and other miscellaneous insns
diff -urpN a/src/gcc/config/aarch64/thunderx2t99.md b/src/gcc/config/aarch64/thunderx2t99.md
--- a/src/gcc/config/aarch64/thunderx2t99.md 1969-12-31 19:00:00.000000000 -0500
+++ b/src/gcc/config/aarch64/thunderx2t99.md 2017-10-20 18:11:52.526064571 -0400
@@ -0,0 +1,443 @@
+;; Cavium ThunderX 2 CN99xx pipeline description
+;; Copyright (C) 2016-2017 Free Software Foundation, Inc.
+;;
+;; Contributed by Cavium, Broadcom and Mentor Embedded.
+
+;; This file is part of GCC.
+
+;; GCC is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3, or (at your option)
+;; any later version.
+
+;; GCC is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+
+;; You should have received a copy of the GNU General Public License
+;; along with GCC; see the file COPYING3. If not see
+;; <http://www.gnu.org/licenses/>.
+
+(define_automaton "thunderx2t99, thunderx2t99_advsimd, thunderx2t99_ldst")
+(define_automaton "thunderx2t99_mult")
+
+(define_cpu_unit "thunderx2t99_i0" "thunderx2t99")
+(define_cpu_unit "thunderx2t99_i1" "thunderx2t99")
+(define_cpu_unit "thunderx2t99_i2" "thunderx2t99")
+
+(define_cpu_unit "thunderx2t99_ls0" "thunderx2t99_ldst")
+(define_cpu_unit "thunderx2t99_ls1" "thunderx2t99_ldst")
+(define_cpu_unit "thunderx2t99_sd" "thunderx2t99_ldst")
+
+; Pseudo-units for multiply pipeline.
+
+(define_cpu_unit "thunderx2t99_i1m1" "thunderx2t99_mult")
+(define_cpu_unit "thunderx2t99_i1m2" "thunderx2t99_mult")
+(define_cpu_unit "thunderx2t99_i1m3" "thunderx2t99_mult")
+
+; Pseudo-units for load delay (assuming dcache hit).
+
+(define_cpu_unit "thunderx2t99_ls0d1" "thunderx2t99_ldst")
+(define_cpu_unit "thunderx2t99_ls0d2" "thunderx2t99_ldst")
+(define_cpu_unit "thunderx2t99_ls0d3" "thunderx2t99_ldst")
+
+(define_cpu_unit "thunderx2t99_ls1d1" "thunderx2t99_ldst")
+(define_cpu_unit "thunderx2t99_ls1d2" "thunderx2t99_ldst")
+(define_cpu_unit "thunderx2t99_ls1d3" "thunderx2t99_ldst")
+
+; Make some aliases for f0/f1.
+(define_cpu_unit "thunderx2t99_f0" "thunderx2t99_advsimd")
+(define_cpu_unit "thunderx2t99_f1" "thunderx2t99_advsimd")
+
+(define_reservation "thunderx2t99_i012" "thunderx2t99_i0|thunderx2t99_i1|thunderx2t99_i2")
+(define_reservation "thunderx2t99_ls01" "thunderx2t99_ls0|thunderx2t99_ls1")
+(define_reservation "thunderx2t99_f01" "thunderx2t99_f0|thunderx2t99_f1")
+
+(define_reservation "thunderx2t99_ls_both" "thunderx2t99_ls0+thunderx2t99_ls1")
+
+; A load with delay in the ls0/ls1 pipes.
+(define_reservation "thunderx2t99_l0delay" "thunderx2t99_ls0,\
+ thunderx2t99_ls0d1,thunderx2t99_ls0d2,\
+ thunderx2t99_ls0d3")
+(define_reservation "thunderx2t99_l1delay" "thunderx2t99_ls1,\
+ thunderx2t99_ls1d1,thunderx2t99_ls1d2,\
+ thunderx2t99_ls1d3")
+(define_reservation "thunderx2t99_l01delay" "thunderx2t99_l0delay|thunderx2t99_l1delay")
+
+;; Branch and call instructions.
+
+(define_insn_reservation "thunderx2t99_branch" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "call,branch"))
+ "thunderx2t99_i2")
+
+;; Integer arithmetic/logic instructions.
+
+; Plain register moves are handled by renaming, and don't create any uops.
+
+(define_insn_reservation "thunderx2t99_regmove" 0
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "mov_reg"))
+ "nothing")
+
+(define_insn_reservation "thunderx2t99_alu_basic" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "alu_imm,alu_sreg,alus_imm,alus_sreg,\
+ adc_reg,adc_imm,adcs_reg,adcs_imm,\
+ logic_reg,logic_imm,logics_reg,logics_imm,\
+ csel,adr,mov_imm,shift_reg,shift_imm,bfm,\
+ rbit,rev,extend,rotate_imm"))
+ "thunderx2t99_i012")
+
+(define_insn_reservation "thunderx2t99_alu_shift" 2
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "alu_shift_imm,alu_ext,alu_shift_reg,\
+ alus_shift_imm,alus_ext,alus_shift_reg,\
+ logic_shift_imm,logics_shift_reg"))
+ "thunderx2t99_i012,thunderx2t99_i012")
+
+(define_insn_reservation "thunderx2t99_div" 13
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "sdiv,udiv"))
+ "thunderx2t99_i1*3")
+
+(define_insn_reservation "thunderx2t99_madd" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "mla,smlal,umlal"))
+ "thunderx2t99_i1,thunderx2t99_i1m1,thunderx2t99_i1m2,thunderx2t99_i1m3,\
+ thunderx2t99_i012")
+
+; NOTE: smull, umull are used for "high part" multiplies too.
+(define_insn_reservation "thunderx2t99_mul" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "mul,smull,umull"))
+ "thunderx2t99_i1,thunderx2t99_i1m1,thunderx2t99_i1m2,thunderx2t99_i1m3")
+
+(define_insn_reservation "thunderx2t99_countbits" 3
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "clz"))
+ "thunderx2t99_i1")
+
+;; Integer loads and stores.
+
+(define_insn_reservation "thunderx2t99_load_basic" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "load1"))
+ "thunderx2t99_ls01")
+
+(define_insn_reservation "thunderx2t99_loadpair" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "load2"))
+ "thunderx2t99_i012,thunderx2t99_ls01")
+
+(define_insn_reservation "thunderx2t99_store_basic" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "store1"))
+ "thunderx2t99_ls01,thunderx2t99_sd")
+
+(define_insn_reservation "thunderx2t99_storepair_basic" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "store2"))
+ "thunderx2t99_ls01,thunderx2t99_sd")
+
+;; FP data processing instructions.
+
+(define_insn_reservation "thunderx2t99_fp_simple" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "ffariths,ffarithd,f_minmaxs,f_minmaxd"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_fp_addsub" 6
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fadds,faddd"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_fp_cmp" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fcmps,fcmpd"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_fp_divsqrt_s" 16
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fdivs,fsqrts"))
+ "thunderx2t99_f0*3|thunderx2t99_f1*3")
+
+(define_insn_reservation "thunderx2t99_fp_divsqrt_d" 23
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fdivd,fsqrtd"))
+ "thunderx2t99_f0*5|thunderx2t99_f1*5")
+
+(define_insn_reservation "thunderx2t99_fp_mul_mac" 6
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fmuls,fmuld,fmacs,fmacd"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_frint" 7
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "f_rints,f_rintd"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_fcsel" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fcsel"))
+ "thunderx2t99_f01")
+
+;; FP miscellaneous instructions.
+
+(define_insn_reservation "thunderx2t99_fp_cvt" 7
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "f_cvtf2i,f_cvt,f_cvti2f"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_fp_mov" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "fconsts,fconstd,fmov,f_mrc"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_fp_mov_to_gen" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "f_mcr"))
+ "thunderx2t99_f01")
+
+;; FP loads and stores.
+
+(define_insn_reservation "thunderx2t99_fp_load_basic" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "f_loads,f_loadd"))
+ "thunderx2t99_ls01")
+
+(define_insn_reservation "thunderx2t99_fp_loadpair_basic" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_load1_2reg"))
+ "thunderx2t99_ls01*2")
+
+(define_insn_reservation "thunderx2t99_fp_store_basic" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "f_stores,f_stored"))
+ "thunderx2t99_ls01,thunderx2t99_sd")
+
+(define_insn_reservation "thunderx2t99_fp_storepair_basic" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_store1_2reg"))
+ "thunderx2t99_ls01,(thunderx2t99_ls01+thunderx2t99_sd),thunderx2t99_sd")
+
+;; ASIMD integer instructions.
+
+(define_insn_reservation "thunderx2t99_asimd_int" 7
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_abd,neon_abd_q,\
+ neon_arith_acc,neon_arith_acc_q,\
+ neon_abs,neon_abs_q,\
+ neon_add,neon_add_q,\
+ neon_neg,neon_neg_q,\
+ neon_add_long,neon_add_widen,\
+ neon_add_halve,neon_add_halve_q,\
+ neon_sub_long,neon_sub_widen,\
+ neon_sub_halve,neon_sub_halve_q,\
+ neon_add_halve_narrow_q,neon_sub_halve_narrow_q,\
+ neon_qabs,neon_qabs_q,\
+ neon_qadd,neon_qadd_q,\
+ neon_qneg,neon_qneg_q,\
+ neon_qsub,neon_qsub_q,\
+ neon_minmax,neon_minmax_q,\
+ neon_reduc_minmax,neon_reduc_minmax_q,\
+ neon_mul_b,neon_mul_h,neon_mul_s,\
+ neon_mul_b_q,neon_mul_h_q,neon_mul_s_q,\
+ neon_sat_mul_b,neon_sat_mul_h,neon_sat_mul_s,\
+ neon_sat_mul_b_q,neon_sat_mul_h_q,neon_sat_mul_s_q,\
+ neon_mla_b,neon_mla_h,neon_mla_s,\
+ neon_mla_b_q,neon_mla_h_q,neon_mla_s_q,\
+ neon_mul_b_long,neon_mul_h_long,\
+ neon_mul_s_long,neon_mul_d_long,\
+ neon_sat_mul_b_long,neon_sat_mul_h_long,\
+ neon_sat_mul_s_long,\
+ neon_mla_b_long,neon_mla_h_long,neon_mla_s_long,\
+ neon_sat_mla_b_long,neon_sat_mla_h_long,\
+ neon_sat_mla_s_long,\
+ neon_shift_acc,neon_shift_acc_q,\
+ neon_shift_imm,neon_shift_imm_q,\
+ neon_shift_reg,neon_shift_reg_q,\
+ neon_shift_imm_long,neon_shift_imm_narrow_q,\
+ neon_sat_shift_imm,neon_sat_shift_imm_q,\
+ neon_sat_shift_reg,neon_sat_shift_reg_q,\
+ neon_sat_shift_imm_narrow_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_reduc_add" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_reduc_add,neon_reduc_add_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_cmp" 7
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_compare,neon_compare_q,neon_compare_zero,\
+ neon_tst,neon_tst_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_logic" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_logic,neon_logic_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_polynomial" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_mul_d_long"))
+ "thunderx2t99_f01")
+
+;; ASIMD floating-point instructions.
+
+(define_insn_reservation "thunderx2t99_asimd_fp_simple" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_fp_abs_s,neon_fp_abs_d,\
+ neon_fp_abs_s_q,neon_fp_abs_d_q,\
+ neon_fp_compare_s,neon_fp_compare_d,\
+ neon_fp_compare_s_q,neon_fp_compare_d_q,\
+ neon_fp_minmax_s,neon_fp_minmax_d,\
+ neon_fp_minmax_s_q,neon_fp_minmax_d_q,\
+ neon_fp_reduc_minmax_s,neon_fp_reduc_minmax_d,\
+ neon_fp_reduc_minmax_s_q,neon_fp_reduc_minmax_d_q,\
+ neon_fp_neg_s,neon_fp_neg_d,\
+ neon_fp_neg_s_q,neon_fp_neg_d_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_fp_arith" 6
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_fp_abd_s,neon_fp_abd_d,\
+ neon_fp_abd_s_q,neon_fp_abd_d_q,\
+ neon_fp_addsub_s,neon_fp_addsub_d,\
+ neon_fp_addsub_s_q,neon_fp_addsub_d_q,\
+ neon_fp_reduc_add_s,neon_fp_reduc_add_d,\
+ neon_fp_reduc_add_s_q,neon_fp_reduc_add_d_q,\
+ neon_fp_mul_s,neon_fp_mul_d,\
+ neon_fp_mul_s_q,neon_fp_mul_d_q,\
+ neon_fp_mla_s,neon_fp_mla_d,\
+ neon_fp_mla_s_q,neon_fp_mla_d_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_fp_conv" 7
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_fp_cvt_widen_s,neon_fp_cvt_narrow_d_q,\
+ neon_fp_to_int_s,neon_fp_to_int_d,\
+ neon_fp_to_int_s_q,neon_fp_to_int_d_q,\
+ neon_fp_round_s,neon_fp_round_d,\
+ neon_fp_round_s_q,neon_fp_round_d_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_fp_div_s" 16
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_fp_div_s,neon_fp_div_s_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_fp_div_d" 23
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_fp_div_d,neon_fp_div_d_q"))
+ "thunderx2t99_f01")
+
+;; ASIMD miscellaneous instructions.
+
+(define_insn_reservation "thunderx2t99_asimd_misc" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_rbit,\
+ neon_bsl,neon_bsl_q,\
+ neon_cls,neon_cls_q,\
+ neon_cnt,neon_cnt_q,\
+ neon_from_gp,neon_from_gp_q,\
+ neon_dup,neon_dup_q,\
+ neon_ext,neon_ext_q,\
+ neon_ins,neon_ins_q,\
+ neon_move,neon_move_q,\
+ neon_fp_recpe_s,neon_fp_recpe_d,\
+ neon_fp_recpe_s_q,neon_fp_recpe_d_q,\
+ neon_fp_recpx_s,neon_fp_recpx_d,\
+ neon_fp_recpx_s_q,neon_fp_recpx_d_q,\
+ neon_rev,neon_rev_q,\
+ neon_dup,neon_dup_q,\
+ neon_permute,neon_permute_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_recip_step" 6
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_fp_recps_s,neon_fp_recps_s_q,\
+ neon_fp_recps_d,neon_fp_recps_d_q,\
+ neon_fp_rsqrts_s, neon_fp_rsqrts_s_q,\
+ neon_fp_rsqrts_d, neon_fp_rsqrts_d_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_lut" 8
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_tbl1,neon_tbl1_q,neon_tbl2_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_elt_to_gr" 6
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_to_gp,neon_to_gp_q"))
+ "thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_ext" 7
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_shift_imm_narrow_q,neon_sat_shift_imm_narrow_q"))
+ "thunderx2t99_f01")
+
+;; ASIMD load instructions.
+
+; NOTE: These reservations attempt to model latency and throughput correctly,
+; but the cycle timing of unit allocation is not necessarily accurate (because
+; insns are split into uops, and those may be issued out-of-order).
+
+(define_insn_reservation "thunderx2t99_asimd_load1_1_mult" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_load1_1reg,neon_load1_1reg_q"))
+ "thunderx2t99_ls01")
+
+(define_insn_reservation "thunderx2t99_asimd_load1_2_mult" 4
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_load1_2reg,neon_load1_2reg_q"))
+ "thunderx2t99_ls_both")
+
+(define_insn_reservation "thunderx2t99_asimd_load1_onelane" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_load1_one_lane,neon_load1_one_lane_q"))
+ "thunderx2t99_l01delay,thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_load1_all" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_load1_all_lanes,neon_load1_all_lanes_q"))
+ "thunderx2t99_l01delay,thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_load2" 5
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_load2_2reg,neon_load2_2reg_q,\
+ neon_load2_one_lane,neon_load2_one_lane_q,\
+ neon_load2_all_lanes,neon_load2_all_lanes_q"))
+ "(thunderx2t99_l0delay,thunderx2t99_f01)|(thunderx2t99_l1delay,\
+ thunderx2t99_f01)")
+
+;; ASIMD store instructions.
+
+; Same note applies as for ASIMD load instructions.
+
+(define_insn_reservation "thunderx2t99_asimd_store1_1_mult" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_store1_1reg,neon_store1_1reg_q"))
+ "thunderx2t99_ls01")
+
+(define_insn_reservation "thunderx2t99_asimd_store1_2_mult" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_store1_2reg,neon_store1_2reg_q"))
+ "thunderx2t99_ls_both")
+
+(define_insn_reservation "thunderx2t99_asimd_store1_onelane" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_store1_one_lane,neon_store1_one_lane_q"))
+ "thunderx2t99_ls01,thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_store2_mult" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_store2_2reg,neon_store2_2reg_q"))
+ "thunderx2t99_ls_both,thunderx2t99_f01")
+
+(define_insn_reservation "thunderx2t99_asimd_store2_onelane" 1
+ (and (eq_attr "tune" "thunderx2t99")
+ (eq_attr "type" "neon_store2_one_lane,neon_store2_one_lane_q"))
+ "thunderx2t99_ls01,thunderx2t99_f01")
|