/usr/src/gcc-5/debian/patches/vulcan-to-thunderx2t99-doc.diff is in gcc-5-source 5.5.0-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 | Description: Add -mcpu=thunderx2t99 support (documentation)
* config/aarch64/aarch64-cores.def: Add thunderx2t99. Change vulcan
to reference thunderx2t99 for the tuning structure
* config/aarch64/aarch64-cost-tables.h (vulcan_extra_costs): Rename to ...
(thunderx2t99_extra_costs): This.
* config/aarch64/aarch64-tune.md: Regenerate.
* config/aarch64/aarch64.c (vulcan_addrcost_table): Rename to ...
(vulcan_addrcost_table): This.
(vulcan_regmove_cost): Rename to ...
(thunderx2t99_regmove_cost): This.
(vulcan_vector_cost): Rename to ...
(thunderx2t99_vector_cost): this.
(vulcan_branch_cost): Rename to ...
(thunderx2t99_branch_cost): This.
(vulcan_tunings): Rename to ...
(thunderx2t99_tunings): This and s/vulcan/thunderx2t99 .
* doc/invoke.texi (AARCH64/mtune): Add thunderx2t99.
.
Backported to gcc-5 by dann frazier <dannf@ubuntu.com>
Author: Andrew Pinski <apinski@cavium.com>
Origin: https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=244235
Bug-Ubuntu: https://bugs.launchpad.net/bugs/1727540
Applied-Upstream: svn://gcc.gnu.org/svn/gcc/trunk@244235
diff -urpN a/src/gcc/doc/invoke.texi b/src/gcc/doc/invoke.texi
--- a/src/gcc/doc/invoke.texi 2017-10-20 17:04:39.461376437 -0400
+++ b/src/gcc/doc/invoke.texi 2017-10-20 17:19:39.658847810 -0400
@@ -12412,7 +12412,7 @@ Specify the name of the target processor
performance of the code. Permissible values for this option are:
@samp{generic}, @samp{cortex-a35}, @samp{cortex-a53}, @samp{cortex-a57},
@samp{cortex-a72}, @samp{exynos-m1}, @samp{qdf24xx}, @samp{thunderx},
-@samp{vulcan}, @samp{xgene1}.
+@samp{thunderx2t99}, @samp{vulcan}, @samp{xgene1}.
Additionally, this option can specify that GCC should tune the performance
of the code for a big.LITTLE system. Permissible values for this
|