/usr/src/gcc-6/debian/patches/gccgo-issue16780.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 | # DP: gccgo: Call default_file_start from s390_asm_file_start
https://gcc.gnu.org/ml/gcc-patches/2016-08/msg01655.html
gcc/
2016-08-23 Ian Lance Taylor <iant@golang.org>
* config/s390/s390.c (s390_asm_file_start): Call
default_file_start.
gcc/testsuite/
2016-08-23 Ian Lance Taylor <iant@golang.org>
* gcc.target/s390/nolrl-1.c: Don't match the file name.
Index: b/src/gcc/config/s390/s390.c
===================================================================
--- a/src/gcc/config/s390/s390.c
+++ b/src/gcc/config/s390/s390.c
@@ -14973,6 +14973,7 @@ s390_vector_alignment (const_tree type)
static void
s390_asm_file_start (void)
{
+ default_file_start ();
s390_asm_output_machine_for_arch (asm_out_file);
}
#endif
Index: b/src/gcc/testsuite/gcc.target/s390/nolrl-1.c
===================================================================
--- a/src/gcc/testsuite/gcc.target/s390/nolrl-1.c
+++ b/src/gcc/testsuite/gcc.target/s390/nolrl-1.c
@@ -16,4 +16,4 @@ bar ()
foo (z);
}
-/* { dg-final { scan-assembler-not "lrl" } } */
+/* { dg-final { scan-assembler-not "\tlrl" } } */
|