/usr/src/gcc-6/debian/patches/gdc-driver-nophobos.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 | # DP: Modify gdc driver to have no libphobos by default.
Index: b/src/gcc/d/d-lang.cc
===================================================================
--- a/src/gcc/d/d-lang.cc
+++ b/src/gcc/d/d-lang.cc
@@ -198,7 +198,7 @@ static void
d_init_options_struct(gcc_options *opts)
{
// GCC options
- opts->x_flag_exceptions = 1;
+ opts->x_flag_exceptions = 0;
// Avoid range issues for complex multiply and divide.
opts->x_flag_complex_method = 2;
Index: b/src/gcc/d/d-spec.c
===================================================================
--- a/src/gcc/d/d-spec.c
+++ b/src/gcc/d/d-spec.c
@@ -62,7 +62,7 @@ static int library = 0;
/* If true, use the standard D runtime library when linking with
standard libraries. */
-static bool need_phobos = true;
+static bool need_phobos = false;
void
lang_specific_driver (cl_decoded_option **in_decoded_options,
|