/usr/src/gcc-6/debian/patches/gdc-updates.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 | # DP: gdc updates up to 20160115.
* Make-lang.in (d-warn): Filter out -Wmissing-format-attribute.
--- a/src/gcc/d/Make-lang.in
+++ b/src/gcc/d/Make-lang.in
@@ -51,7 +51,7 @@
cp gdc$(exeext) gdc-cross$(exeext)
# Filter out pedantic and virtual overload warnings.
-d-warn = $(filter-out -pedantic -Woverloaded-virtual, $(STRICT_WARN))
+d-warn = $(filter-out -pedantic -Woverloaded-virtual -Wmissing-format-attribute, $(STRICT_WARN))
# D Frontend has slightly relaxed warnings compared to rest of GDC.
DMD_WARN_CXXFLAGS = -Wno-deprecated -Wstrict-aliasing -Wuninitialized
--- a/src/libphobos/src/std/internal/math/gammafunction.d
+++ b/src/libphobos/src/std/internal/math/gammafunction.d
@@ -420,7 +420,7 @@
if ( p == q )
return real.infinity;
int intpart = cast(int)(p);
- real sgngam = 1;
+ real sgngam = 1.0L;
if ( (intpart & 1) == 0 )
sgngam = -1;
z = q - p;
|