/usr/src/gcc-6/debian/patches/libgnatprj-link.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 | # DP: Don't link libgnatprj using --no-allow-shlib-undefined on older releases.
in precise:
/lib/x86_64-linux-gnu/libc.so.6: undefined reference to `_rtld_global@GLIBC_PRIVATE'
/lib/x86_64-linux-gnu/libc.so.6: undefined reference to `_dl_argv@GLIBC_PRIVATE'
/lib/x86_64-linux-gnu/libc.so.6: undefined reference to `_rtld_global_ro@GLIBC_PRIVATE'
/lib/x86_64-linux-gnu/libc.so.6: undefined reference to `__libc_enable_secure@GLIBC_PRIVATE'
/lib/x86_64-linux-gnu/libc.so.6: undefined reference to `__tls_get_addr@GLIBC_2.3'
collect2: error: ld returned 1 exit status
--- a/src/libgnatprj/Makefile.in
+++ b/src/libgnatprj/Makefile.in
@@ -74,7 +74,7 @@
libgnatprj.so.$(LIB_VERSION): $(addprefix obj-shared/,$(OBJECTS))
: # Make libgnatprj.so
- $(GCC) -o $@ -shared -fPIC -Wl,--soname,$@ -Wl,--no-allow-shlib-undefined \
+ $(GCC) -o $@ -shared -fPIC -Wl,--soname,$@ \
$^ $(addprefix ../libiberty/pic/,$(LIBIBERTY_OBJECTS)) \
-L../gcc/ada/rts -lgnat-$(LIB_VERSION) \
-L../libgnatvsn -lgnatvsn
|