/usr/src/gcc-6/debian/patches/m68k-revert-pr45144.diff is in gcc-6-source 6.4.0-17ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | [revert the minor PR45144 missed-optimization fix because it
results in miscompilation of gnat on m68k with gcc-4.6 and 4.5;
with gcc-4.7 other changes mask the issue <mikpe@it.uu.se>]
PR ada/48835
Index: b/src/gcc/tree-sra.c
===================================================================
--- a/src/gcc/tree-sra.c
+++ b/src/gcc/tree-sra.c
@@ -927,9 +927,6 @@ scalarizable_type_p (tree type)
{
tree ft = TREE_TYPE (fld);
- if (DECL_BIT_FIELD (fld))
- return false;
-
if (!is_gimple_reg_type (ft)
&& !scalarizable_type_p (ft))
return false;
|