/usr/src/gcc-8/debian/patches/ada-arm.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 | DP: Improve support for ZCX on arm.
Index: b/src/gcc/ada/gcc-interface/Makefile.in
===================================================================
--- a/src/gcc/ada/gcc-interface/Makefile.in
+++ b/src/gcc/ada/gcc-interface/Makefile.in
@@ -1595,7 +1595,10 @@ ifeq ($(strip $(filter-out arm% linux-gn
ifeq ($(strip $(filter-out arm%b,$(target_cpu))),)
EH_MECHANISM=
else
- EH_MECHANISM=-arm
+ # Special case; the GCC exception mechanism is supported under
+ # another name and with different files than for other
+ # target_cpus.
+ override EH_MECHANISM=-arm
endif
TOOLS_TARGET_PAIRS = indepsw.adb<indepsw-gnu.adb
|