/usr/src/gcc-8/debian/patches/ada-drop-termio-h.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 | Description: ada/terminals.c: remove obsolete termio.h
On all architectures, the terminals.c source file #includes
<termios.h> and declares variables with type struct termios.
.
Some platforms provide a compatibility termio.h, which only defines
the termio structure.
.
terminals.c also #includes <termio.h>, probably for historical
reasons since no termio structure is ever used.
.
Drop the #include instead of maintaining a list of architectures.
Author: Nicolas Boulenguez <nicolas@debian.org>
Bug-Debian: https://bugs.debian.org/845159
Forwarded: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81103
Index: b/src/gcc/ada/terminals.c
===================================================================
--- a/src/gcc/ada/terminals.c
+++ b/src/gcc/ada/terminals.c
@@ -1107,14 +1107,6 @@ __gnat_setup_winsize (void *desc, int ro
#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
-
-/* On some system termio is either absent or including it will disable termios
- (HP-UX) */
-#if !defined (__hpux__) && !defined (BSD) && !defined (__APPLE__) \
- && !defined (__rtems__) && !defined (__QNXNTO__)
-# include <termio.h>
-#endif
-
#include <sys/ioctl.h>
#include <termios.h>
#include <fcntl.h>
@@ -1130,7 +1122,6 @@ __gnat_setup_winsize (void *desc, int ro
# include <sys/signal.h>
#endif
#if defined (__hpux__)
-# include <sys/termio.h>
# include <sys/stropts.h>
#endif
|