/usr/src/gcc-8/debian/patches/canonical-cpppath.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 | # DP: Don't use any relative path names for the standard include paths.
Index: b/src/gcc/incpath.c
===================================================================
--- a/src/gcc/incpath.c
+++ b/src/gcc/incpath.c
@@ -172,6 +172,14 @@ add_standard_paths (const char *sysroot,
str = reconcat (str, str, dir_separator_str,
imultiarch, NULL);
}
+ {
+ char *rp = lrealpath (str);
+ if (rp)
+ {
+ free (str);
+ str = rp;
+ }
+ }
add_path (str, INC_SYSTEM, p->cxx_aware, false);
}
}
@@ -246,6 +254,14 @@ add_standard_paths (const char *sysroot,
else
str = reconcat (str, str, dir_separator_str, imultiarch, NULL);
}
+ {
+ char *rp = lrealpath (str);
+ if (rp)
+ {
+ free (str);
+ str = rp;
+ }
+ }
add_path (str, INC_SYSTEM, p->cxx_aware, false);
}
|