/usr/src/gcc-8/debian/patches/gdc-cross-install-location.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 | Index: b/src/libphobos/configure.ac
===================================================================
--- a/src/libphobos/configure.ac
+++ b/src/libphobos/configure.ac
@@ -152,6 +152,8 @@ PHOBOS_SOVERSION="76:2:0"
AC_SUBST([DRUNTIME_SOVERSION])
AC_SUBST([PHOBOS_SOVERSION])
+# trigger rebuild of the configure file
+
# Set default flags (after DRUNTIME_WERROR!)
if test -z "$GDCFLAGS"; then
GDCFLAGS="-Wall $WERROR_FLAG -g -frelease -O2"
Index: b/src/libphobos/m4/druntime.m4
===================================================================
--- a/src/libphobos/m4/druntime.m4
+++ b/src/libphobos/m4/druntime.m4
@@ -78,7 +78,7 @@ AC_DEFUN([DRUNTIME_INSTALL_DIRECTORIES],
AC_SUBST(toolexeclibdir)
# Default case for install directory for D sources files.
- gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
+ gdc_include_dir='${libdir}/gcc-cross/${target_alias}'/${d_gcc_ver}/include/d
AC_SUBST(gdc_include_dir)
])
|