/usr/src/gcc-8/debian/patches/gdc-multiarch.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 | # DP: Set the D target include directory to a multiarch location.
--- a/src/gcc/d/Make-lang.in
+++ b/src/gcc/d/Make-lang.in
@@ -61,7 +61,11 @@
$(D_DMD_H)
-gcc_d_target_include_dir=$(gcc_d_include_dir)/$(target_noncanonical)
+ifneq (,$(MULTIARCH_DIRNAME))
+ gcc_d_target_include_dir = /usr/include/$(MULTIARCH_DIRNAME)/d/$(version)
+else
+ gcc_d_target_include_dir=$(gcc_d_include_dir)/$(target_noncanonical)
+endif
# Name of phobos library
D_LIBPHOBOS = -DLIBPHOBOS=\"gphobos2\"
|