/usr/src/gcc-8/debian/patches/gdc-profiledbuild.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 | # DP: Don't build gdc build tools idgen and impcnvgen with profiling flags
Index: b/src/gcc/d/Make-lang.in
===================================================================
--- a/src/gcc/d/Make-lang.in
+++ b/src/gcc/d/Make-lang.in
@@ -314,6 +314,14 @@ d/idgen: d/idgen.dmdgen.o
d/impcvgen: d/impcnvgen.dmdgen.o
+$(LINKER_FOR_BUILD) $(BUILD_LINKER_FLAGS) $(BUILD_LDFLAGS) -o $@ $^
+d/idgen.dmdgen.o: d/dfrontend/idgen.c
+ $(filter-out -fprofile-%,$(DMD_COMPILE)) $(D_INCLUDES) $<
+ $(POSTCOMPILE)
+
+d/impcnvgen.dmdgen.o: $(srcdir)/d/dfrontend/impcnvgen.c
+ $(filter-out -fprofile-%,$(DMDGEN_COMPILE)) $(D_INCLUDES) $<
+ $(POSTCOMPILE)
+
# Generated sources.
d/id.c: d/idgen
cd d && ./idgen
|