/usr/src/gcc-8/debian/patches/gdc-shared-by-default.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 | # DP: Link with the shared libphobos library by default.
Index: b/src/gcc/d/d-spec.c
===================================================================
--- a/src/gcc/d/d-spec.c
+++ b/src/gcc/d/d-spec.c
@@ -395,9 +395,9 @@ lang_specific_driver (cl_decoded_option
/* Add `-lgphobos' if we haven't already done so. */
if (library > 0 && need_phobos)
{
- /* Default to static linking. */
+ /* Default to shared linking. */
if (library == 1)
- library = 2;
+ library = 3;
#ifdef HAVE_LD_STATIC_DYNAMIC
if (library == 3 && static_link)
|