/usr/src/gcc-8/debian/patches/gdc-updates.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 | # DP: gdc updates up to 20160115.
* Make-lang.in (d-warn): Filter out -Wmissing-format-attribute.
Index: b/src/gcc/d/Make-lang.in
===================================================================
--- a/src/gcc/d/Make-lang.in
+++ b/src/gcc/d/Make-lang.in
@@ -46,7 +46,7 @@ gdc-cross$(exeext): gdc$(exeext)
cp gdc$(exeext) gdc-cross$(exeext)
# Filter out pedantic and virtual overload warnings.
-d-warn = $(filter-out -pedantic -Woverloaded-virtual, $(STRICT_WARN))
+d-warn = $(filter-out -pedantic -Woverloaded-virtual -Wmissing-format-attribute, $(STRICT_WARN))
# Also filter out warnings for missing format attributes in the D Frontend.
DMD_WARN_CXXFLAGS = $(filter-out -Wmissing-format-attribute, $(WARN_CXXFLAGS))
Index: b/src/libphobos/src/std/internal/math/gammafunction.d
===================================================================
--- a/src/libphobos/src/std/internal/math/gammafunction.d
+++ b/src/libphobos/src/std/internal/math/gammafunction.d
@@ -460,7 +460,7 @@ real logGamma(real x)
if ( p == q )
return real.infinity;
int intpart = cast(int)(p);
- real sgngam = 1;
+ real sgngam = 1.0L;
if ( (intpart & 1) == 0 )
sgngam = -1;
z = q - p;
|