/usr/src/gcc-8/debian/patches/go-testsuite.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 | # DP: Skip Go testcase on AArch64 which hangs on the buildds.
Index: b/src/gcc/testsuite/go.test/go-test.exp
===================================================================
--- a/src/gcc/testsuite/go.test/go-test.exp
+++ b/src/gcc/testsuite/go.test/go-test.exp
@@ -405,6 +405,14 @@ proc go-gc-tests { } {
continue
}
+ # Hangs on the buildds
+ if { [istarget "aarch64*-*-*"] } {
+ if { [string match "*go.test/test/chan/select5.go" $test] } {
+ untested $test
+ continue
+ }
+ }
+
if { [file tail $test] == "init1.go" } {
# This tests whether GC runs during init, which for gccgo
# it currently does not.
|