/usr/src/gcc-8/debian/patches/pr47818.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 | Description: allow pragma Assert with No_Implementation_Pragmas restriction.
Author: Eugeniy Meshcheryakov <eugen@debian.org>
Forwarded: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=47818
Index: b/src/gcc/ada/sem_prag.adb
===================================================================
--- a/src/gcc/ada/sem_prag.adb
+++ b/src/gcc/ada/sem_prag.adb
@@ -17631,7 +17631,16 @@ package body Sem_Prag is
Typ_Arg : Node_Id;
begin
- GNAT_Pragma;
+ -- This could be a rewritten pragma Assert. If it is the case
+ -- then don't check restrictions, because they are different for
+ -- pragma Assert and were already checked.
+
+ if Nkind (Original_Node (N)) /= N_Pragma
+ or else Pragma_Name (Original_Node (N)) /= Name_Assert
+ then
+ GNAT_Pragma;
+ end if;
+
Check_At_Least_N_Arguments (2);
Check_At_Most_N_Arguments (3);
Check_Optional_Identifier (Arg1, Name_Entity);
|