/usr/src/gcc-8/debian/patches/pr67899.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 | # DP: Proposed patch for PR sanitizer/67899
Index: b/src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h
===================================================================
--- a/src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h
+++ b/src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.h
@@ -606,11 +606,10 @@ namespace __sanitizer {
#else
__sanitizer_sigset_t sa_mask;
#ifndef __mips__
-#if defined(__sparc__)
- unsigned long sa_flags;
-#else
- int sa_flags;
+#if defined(__sparc__) && defined(__arch64__)
+ int __pad;
#endif
+ int sa_flags;
#endif
#endif
#if SANITIZER_LINUX
@@ -640,7 +639,8 @@ namespace __sanitizer {
void (*handler)(int signo);
void (*sigaction)(int signo, void *info, void *ctx);
};
- unsigned long sa_flags;
+ int __pad;
+ int sa_flags;
void (*sa_restorer)(void);
__sanitizer_kernel_sigset_t sa_mask;
};
|