/usr/src/gcc-8/debian/patches/testsuite-glibc-warnings.diff is in gcc-8-source 8-20180414-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 | # DP: fix testcases that triggered -Wunused-result with glibc
# DP: Author: Steve Beattie <steve.beattie@canonical.com>
---
src/gcc/testsuite/c-c++-common/cilk-plus/AN/comma_exp.c | 2 +-
src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
Index: b/src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c
===================================================================
--- a/src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c
+++ b/src/gcc/testsuite/c-c++-common/tsan/fd_pipe_race.c
@@ -1,5 +1,5 @@
/* { dg-shouldfail "tsan" } */
-/* { dg-additional-options "-ldl" } */
+/* { dg-additional-options "-Wno-unused-result -ldl" } */
#include <pthread.h>
#include <unistd.h>
|