/usr/src/glibc/debian/rules.d/debhelper.mk is in eglibc-source 2.15-0ubuntu10.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 | # This is so horribly wrong. libc-pic does a whole pile of gratuitous
# renames. There's very little we can do for now. Maybe after
# Sarge releases we can consider breaking packages, but certainly not now.
$(stamp)binaryinst_$(libc)-pic:: debhelper
@echo Running special kludge for $(libc)-pic
dh_testroot
dh_installdirs -p$(curpass)
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/libc_pic.a debian/$(libc)-pic/$(libdir)/.
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/libc.map debian/$(libc)-pic/$(libdir)/libc_pic.map
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/elf/soinit.os debian/$(libc)-pic/$(libdir)/libc_pic/soinit.o
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/elf/sofini.os debian/$(libc)-pic/$(libdir)/libc_pic/sofini.o
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/math/libm_pic.a debian/$(libc)-pic/$(libdir)/.
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/libm.map debian/$(libc)-pic/$(libdir)/libm_pic.map
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/resolv/libresolv_pic.a debian/$(libc)-pic/$(libdir)/.
install --mode=0644 build-tree/$(DEB_HOST_ARCH)-libc/libresolv.map debian/$(libc)-pic/$(libdir)/libresolv_pic.map
# Some per-package extra files to install.
define libc-bin_extra_debhelper_pkg_install
# dh_installmanpages thinks that .so is a language.
install --mode=0644 debian/local/manpages/ld.so.8 debian/libc-bin/usr/share/man/man8/ld.so.8
endef
# Should each of these have per-package options?
$(patsubst %,binaryinst_%,$(DEB_ARCH_REGULAR_PACKAGES) $(DEB_INDEP_REGULAR_PACKAGES)) :: binaryinst_% : $(stamp)binaryinst_%
# Make sure the debug packages are built last, since other packages may add
# files to them.
debug-packages = $(filter %-dbg,$(DEB_ARCH_REGULAR_PACKAGES))
non-debug-packages = $(filter-out %-dbg,$(DEB_ARCH_REGULAR_PACKAGES))
$(patsubst %,$(stamp)binaryinst_%,$(debug-packages)):: $(patsubst %,$(stamp)binaryinst_%,$(non-debug-packages))
$(patsubst %,$(stamp)binaryinst_%,$(DEB_ARCH_REGULAR_PACKAGES) $(DEB_INDEP_REGULAR_PACKAGES)):: $(patsubst %,$(stamp)install_%,$(EGLIBC_PASSES)) debhelper
@echo Running debhelper for $(curpass)
dh_testroot
dh_installdirs -p$(curpass)
dh_install -p$(curpass) $(if $(filter $(curpass),libc6-i386 libc6-powerpc),debian/tmp-$(patsubst libc6-%,%,$(curpass))/etc/ld.so.conf.d /etc)
dh_installman -p$(curpass)
dh_installinfo -p$(curpass)
dh_installdebconf -p$(curpass)
if [ $(curpass) = glibc-doc ] ; then \
dh_installchangelogs -p$(curpass) ; \
else \
dh_installchangelogs -p$(curpass) debian/changelog.upstream ; \
fi
dh_installinit -p$(curpass)
dh_installdocs -p$(curpass)
dh_lintian -p $(curpass)
dh_link -p$(curpass)
dh_bugfiles -p$(curpass)
set -ex; case $(curpass) in libc-bin) \
mv debian/$(curpass)/sbin/ldconfig \
debian/$(curpass)/sbin/ldconfig.real; \
install -m755 -o0 -g0 debian/local/ldconfig_wrap \
debian/$(curpass)/sbin/ldconfig; \
;; esac
# extra_debhelper_pkg_install is used for debhelper.mk only.
# when you want to install extra packages, use extra_pkg_install.
$(call xx,extra_debhelper_pkg_install)
$(call xx,extra_pkg_install)
ifeq ($(filter nostrip,$(DEB_BUILD_OPTIONS)),)
# libpthread must be stripped specially; GDB needs the
# non-dynamic symbol table in order to load the thread
# debugging library. We keep a full copy of the symbol
# table in libc6-dbg but basic thread debugging should
# work even without that package installed.
# strip *.o files as dh_strip does not (yet?) do it.
if test "$(NOSTRIP_$(curpass))" != 1; then \
if test "$(NODEBUG_$(curpass))" != 1; then \
dh_strip -p$(curpass) -Xlibpthread --dbg-package=$(libc)-dbg; \
(cd debian/$(curpass); \
find . -name libpthread-\*.so -exec objcopy \
--only-keep-debug '{}' ../$(libc)-dbg/usr/lib/debug/'{}' \
';' || true; \
find . -name libpthread-\*.so -exec objcopy \
--add-gnu-debuglink=../$(libc)-dbg/usr/lib/debug/'{}' \
'{}' ';' || true); \
find debian/$(curpass) -name libpthread-\*.so -exec \
strip --strip-debug --remove-section=.comment \
--remove-section=.note '{}' ';' || true; \
\
(cd debian/$(curpass); \
find . -name \*crt\*.o -exec objcopy \
--only-keep-debug '{}' ../$(libc)-dbg/usr/lib/debug/'{}' \
';' || true; \
find . -name \*crt\*.o -exec objcopy \
--add-gnu-debuglink=../$(libc)-dbg/usr/lib/debug/'{}' \
'{}' ';' || true); \
find debian/$(curpass) -name \*crt\*.o -exec \
strip --strip-debug --remove-section=.comment \
--remove-section=.note '{}' ';' || true; \
else \
dh_strip -p$(curpass) -Xlibpthread; \
fi \
fi
# ARM archs always use multiarch locations, don't let libc6-dbg conflict
if test "$(curpass)" = "$(libc)-dbg"; then \
if test "$(DEB_HOST_ARCH)" = "armel"; then \
rm -rf debian/$(curpass)/usr/lib/debug/lib/arm-linux-gnueabihf; \
rm -rf debian/$(curpass)/usr/lib/debug/usr/lib/arm-linux-gnueabihf; \
fi; \
if test "$(DEB_HOST_ARCH)" = "armhf"; then \
rm -rf debian/$(curpass)/usr/lib/debug/lib/arm-linux-gnueabi; \
rm -rf debian/$(curpass)/usr/lib/debug/usr/lib/arm-linux-gnueabi; \
fi; \
fi
endif
dh_compress -p$(curpass)
dh_fixperms -p$(curpass) -Xpt_chown
# Use this instead of -X to dh_fixperms so that we can use
# an unescaped regular expression. ld.so must be executable;
# libc.so and NPTL's libpthread.so print useful version
# information when executed.
find debian/$(curpass) -type f \( -regex '.*/ld.*so' \
-o -regex '.*/libpthread-.*so' \
-o -regex '.*/libc-.*so' \) \
-exec chmod a+x '{}' ';'
dh_makeshlibs -X/usr/lib/debug -p$(curpass) -V "$(call xx,shlib_dep)"
# Add relevant udeb: lines in shlibs files
chmod a+x debian/shlibs-add-udebs
./debian/shlibs-add-udebs $(curpass)
if [ -f debian/$(curpass).triggers ] ; then \
install -m 644 -o root -g root debian/$(curpass).triggers \
debian/$(curpass)/DEBIAN/triggers ; \
fi
dh_installdeb -p$(curpass)
dh_shlibdeps -p$(curpass)
dh_gencontrol -p$(curpass)
if [ $(curpass) = nscd ] ; then \
sed -i -e "s/\(Depends:.*libc[0-9.]\+\)-[a-z0-9]\+/\1/" debian/nscd/DEBIAN/control ; \
fi
dh_md5sums -p$(curpass)
# We adjust the compression format depending on the package:
# - libc*-dbg and locales-all contains highly compressible data
# - other packages use the default gzip format
case $(curpass) in \
libc*-dbg | locales-all) \
dh_builddeb -p$(curpass) -- -Zxz -z7 ;; \
*) \
dh_builddeb -p$(curpass) ;; \
esac
touch $@
$(patsubst %,binaryinst_%,$(DEB_UDEB_PACKAGES)) :: binaryinst_% : $(stamp)binaryinst_%
$(patsubst %,$(stamp)binaryinst_%,$(DEB_UDEB_PACKAGES)): debhelper $(patsubst %,$(stamp)install_%,$(EGLIBC_PASSES))
@echo Running debhelper for $(curpass)
dh_testroot
dh_installdirs -p$(curpass)
dh_install -p$(curpass)
dh_strip -p$(curpass)
# when you want to install extra packages, use extra_pkg_install.
$(call xx,extra_pkg_install)
dh_compress -p$(curpass)
dh_fixperms -p$(curpass)
find debian/$(curpass) -type f \( -regex '.*/ld.*so' \
-o -regex '.*/libpthread-.*so' \
-o -regex '.*/libc-.*so' \) \
-exec chmod a+x '{}' ';'
dh_installdeb -p$(curpass)
# dh_shlibdeps -p$(curpass)
dh_gencontrol -p$(curpass)
dh_builddeb -p$(curpass)
touch $@
debhelper: $(stamp)debhelper-common $(patsubst %,$(stamp)debhelper_%,$(EGLIBC_PASSES))
$(stamp)debhelper-common:
for x in `find debian/debhelper.in -maxdepth 1 -type f`; do \
y=debian/`basename $$x`; \
cp $$x $$y; \
sed -e "s#BUILD-TREE#$(build-tree)#" -i $$y; \
sed -e "s#LIBC#$(libc)#" -i $$y; \
sed -e "s#EXIT_CHECK##" -i $$y; \
sed -e "s#DEB_HOST_ARCH#$(DEB_HOST_ARCH)#" -i $$y; \
sed -e "/NSS_CHECK/r debian/script.in/nsscheck.sh" -i $$y; \
sed -e "/NOHWCAP/r debian/script.in/nohwcap.sh" -i $$y; \
sed -e "s#DEB_SRCDIR#.#" -i $$y; \
sed -e "s#CURRENT_VER#$(DEB_VERSION)#" -i $$y; \
case $$y in \
*.install) \
sed -e "s/^#.*//" -i $$y ; \
;; \
esac; \
done
# Substitute __PROVIDED_LOCALES__.
perl -i -pe 'BEGIN {undef $$/; open(IN, "debian/tmp-libc/usr/share/i18n/SUPPORTED"); $$j=<IN>;} s/__PROVIDED_LOCALES__/$$j/g;' debian/locales.config debian/locales.postinst
# Generate common substvars files.
echo "locale:Depends=$(shell perl debian/debver2localesdep.pl $(LOCALES_DEP_VER))" > tmp.substvars
echo "locale-compat:Depends=$(shell perl debian/debver2localesdep.pl $(LOCALES_COMPAT_VER))" >> tmp.substvars
for pkg in $(DEB_ARCH_REGULAR_PACKAGES) $(DEB_INDEP_REGULAR_PACKAGES) $(DEB_UDEB_PACKAGES); do \
cp tmp.substvars debian/$$pkg.substvars; \
done
rm -f tmp.substvars
touch $@
ifeq ($(DEB_STAGE),stage1)
$(patsubst %,debhelper_%,$(EGLIBC_PASSES)) :: debhelper_% : $(stamp)debhelper_%
$(stamp)debhelper_%: $(stamp)debhelper-common $(stamp)install_%
libdir=$(call xx,libdir) ; \
slibdir=$(call xx,slibdir) ; \
rtlddir=$(call xx,rtlddir) ; \
curpass=$(curpass) ; \
templates="libc-dev" ;\
pass="" ; \
suffix="" ;\
for t in $$templates ; do \
for s in debian/$$t$$pass.* ; do \
t=`echo $$s | sed -e "s#libc\(.*\)$$pass#$(libc)\1$$suffix#"` ; \
if [ "$$s" != "$$t" ] ; then \
cp $$s $$t ; \
fi ; \
sed -e "s#TMPDIR#debian/tmp-$$curpass#g" -i $$t; \
sed -e "s#RTLDDIR#$$rtlddir#g" -i $$t; \
sed -e "s#SLIBDIR#$$slibdir#g" -i $$t; \
done ; \
done
egrep -v "LIBDIR.*.a " debian/libc6-dev.install >debian/libc6-dev.install-
mv debian/libc6-dev.install- debian/libc6-dev.install
sed -e "s#LIBDIR#lib#g" -i debian/libc6-dev.install
else
$(patsubst %,debhelper_%,$(EGLIBC_PASSES)) :: debhelper_% : $(stamp)debhelper_%
$(stamp)debhelper_%: $(stamp)debhelper-common $(stamp)install_%
libdir=$(call xx,libdir) ; \
slibdir=$(call xx,slibdir) ; \
rtlddir=$(call xx,rtlddir) ; \
curpass=$(curpass) ; \
rtld_so=`LANG=C LC_ALL=C readelf -l debian/tmp-$$curpass/usr/bin/iconv | grep "interpreter" | sed -e 's/.*interpreter: \(.*\)]/\1/g'`; \
case "$$curpass:$$slibdir" in \
libc:*) \
templates="libc libc-dev libc-pic libc-prof libc-udeb libnss-dns-udeb libnss-files-udeb" \
pass="" \
suffix="" \
;; \
*:/lib32 | *:/lib64 | *:/lib/arm-linux-gnueabi*) \
templates="libc libc-dev" \
pass="-alt" \
suffix="-$(curpass)" \
;; \
*:*) \
templates="libc" \
pass="-otherbuild" \
suffix="-$(curpass)" \
;; \
esac ; \
for t in $$templates ; do \
for s in debian/$$t$$pass.* ; do \
t=`echo $$s | sed -e "s#libc\(.*\)$$pass#$(libc)\1$$suffix#"` ; \
if [ "$$s" != "$$t" ] ; then \
cp $$s $$t ; \
fi ; \
sed -e "s#TMPDIR#debian/tmp-$$curpass#g" -i $$t; \
sed -e "s#RTLDDIR#$$rtlddir#g" -i $$t; \
sed -e "s#SLIBDIR#$$slibdir#g" -i $$t; \
sed -e "s#LIBDIR#$$libdir#g" -i $$t; \
sed -e "s#FLAVOR#$$curpass#g" -i $$t; \
sed -e "s#RTLD_SO#$$rtld_so#g" -i $$t ; \
done ; \
done
endif
touch $@
clean::
dh_clean
rm -f debian/*.install*
rm -f debian/*.install.*
rm -f debian/*.manpages
rm -f debian/*.links
rm -f debian/*.postinst
rm -f debian/*.preinst
rm -f debian/*.postinst
rm -f debian/*.prerm
rm -f debian/*.postrm
rm -f debian/*.info
rm -f debian/*.init
rm -f debian/*.config
rm -f debian/*.templates
rm -f debian/*.dirs
rm -f debian/*.docs
rm -f debian/*.doc-base
rm -f debian/*.generated
rm -f debian/*.lintian-overrides
rm -f debian/*.NEWS
rm -f debian/*.README.Debian
rm -f debian/*.triggers
rm -f $(stamp)binaryinst*
|