/usr/src/gcc-4.4/debian/patches/gcc-java-align-data.diff is in gcc-4.4-source 4.4.7-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 | # DP: java: Align data in .rodata.jutf8.* sections, taken from the trunk.
http://gcc.gnu.org/ml/java-patches/2010-q3/msg00014.html
--- a/src/gcc/java/class.c
+++ b/src/gcc/java/class.c
@@ -972,6 +972,7 @@
TREE_READONLY (decl) = 1;
TREE_THIS_VOLATILE (decl) = 0;
DECL_INITIAL (decl) = cinit;
+ DECL_USER_ALIGN (decl) = 1;
if (HAVE_GAS_SHF_MERGE)
{
|