/usr/src/gcc-4.4/debian/patches/gnat-snapshot-build-fix.diff is in gcc-4.4-source 4.4.7-1ubuntu2.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 | # DP: Let gnat-4.4 build with gnat snapshots from the trunk (20100803)
2010-06-22 Ed Schonberg <schonberg@adacore.com>
* uintp.adb: Fix scope error in operator call.
Index: gcc/ada/uintp.adb
===================================================================
--- a/src/gcc/ada/uintp.adb (revision 161146)
+++ b/src/gcc/ada/uintp.adb (revision 161147)
@@ -239,7 +239,7 @@
function Hash_Num (F : Int) return Hnum is
begin
- return Standard."mod" (F, Hnum'Range_Length);
+ return Types."mod" (F, Hnum'Range_Length);
end Hash_Num;
---------------
|