/usr/src/linux-source-3.13.0/debian/rules.d/4-checks.mk is in linux-source-3.13.0 3.13.0-48.80.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 | # Check ABI for package against last release (if not same abinum)
abi-check-%: $(stampdir)/stamp-build-%
@echo Debug: $@
install -d $(abidir)
sed -e 's/^\(.\+\)[[:space:]]\+\(.\+\)[[:space:]]\(.\+\)$$/\3 \2 \1/' \
$(builddir)/build-$*/Module.symvers | sort > $(abidir)/$*
@perl -f $(DROOT)/scripts/abi-check "$*" "$(prev_abinum)" "$(abinum)" \
"$(prev_abidir)" "$(abidir)" "$(skipabi)"
# Check the module list against the last release (always)
module-check-%: $(stampdir)/stamp-build-%
@echo Debug: $@
install -d $(abidir)
find $(builddir)/build-$*/ -name \*.ko | \
sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $(abidir)/$*.modules
@perl -f $(DROOT)/scripts/module-check "$*" \
"$(prev_abidir)" "$(abidir)" $(skipmodule)
checks-%: module-check-% abi-check-%
@echo Debug: $@
# Check the config against the known options list.
config-prepare-check-%: $(stampdir)/stamp-prepare-tree-%
@echo Debug: $@
@perl -f $(DROOT)/scripts/config-check \
$(builddir)/build-$*/.config "$(arch)" "$*" "$(sharedconfdir)" "$(skipconfig)"
|