/usr/src/gcc-4.8/debian/patches/gdc-4.8-doc.diff is in gcc-4.8-source 4.8.2-19ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 | # DP: This implements D language support in the GCC back end, and adds
# DP: relevant documentation about the GDC front end (documentation part).
--- a/src/gcc/doc/frontends.texi
+++ b/src/gcc/doc/frontends.texi
@@ -9,6 +9,7 @@
@cindex GNU Compiler Collection
@cindex GNU C Compiler
@cindex Ada
+@cindex D
@cindex Fortran
@cindex Go
@cindex Java
@@ -17,7 +18,7 @@
GCC stands for ``GNU Compiler Collection''. GCC is an integrated
distribution of compilers for several major programming languages. These
languages currently include C, C++, Objective-C, Objective-C++, Java,
-Fortran, Ada, and Go.
+Fortran, Ada, D and Go.
The abbreviation @dfn{GCC} has multiple meanings in common use. The
current official meaning is ``GNU Compiler Collection'', which refers
--- a/src/gcc/doc/install.texi
+++ b/src/gcc/doc/install.texi
@@ -1350,12 +1350,12 @@ their runtime libraries should be built.
grep language= */config-lang.in
@end smallexample
Currently, you can use any of the following:
-@code{all}, @code{ada}, @code{c}, @code{c++}, @code{fortran},
+@code{all}, @code{ada}, @code{c}, @code{c++}, @code{d}, @code{fortran},
@code{go}, @code{java}, @code{objc}, @code{obj-c++}.
Building the Ada compiler has special requirements, see below.
If you do not pass this flag, or specify the option @code{all}, then all
default languages available in the @file{gcc} sub-tree will be configured.
-Ada, Go and Objective-C++ are not default languages; the rest are.
+Ada, D, Go and Objective-C++ are not default languages; the rest are.
@item --enable-stage1-languages=@var{lang1},@var{lang2},@dots{}
Specify that a particular subset of compilers and their runtime
--- a/src/gcc/doc/invoke.texi
+++ b/src/gcc/doc/invoke.texi
@@ -1164,6 +1164,15 @@ called @dfn{specs}.
Ada source code file containing a library unit body (a subprogram or
package body). Such files are also called @dfn{bodies}.
+@item @var{file}.d
+D source code file.
+
+@item @var{file}.di
+D interface code file.
+
+@item @var{file}.dd
+D documentation code file.
+
@c GCC also knows about some suffixes for languages not yet included:
@c Pascal:
@c @var{file}.p
@@ -1199,6 +1208,7 @@ objective-c objective-c-header objecti
objective-c++ objective-c++-header objective-c++-cpp-output
assembler assembler-with-cpp
ada
+d
f77 f77-cpp-input f95 f95-cpp-input
go
java
--- a/src/gcc/doc/sourcebuild.texi
+++ b/src/gcc/doc/sourcebuild.texi
@@ -113,6 +113,9 @@ The Objective-C and Objective-C++ runtim
@item libquadmath
The runtime support library for quad-precision math operations.
+@item libphobos
+The D standard runtime library.
+
@item libssp
The Stack protector runtime library.
--- a/src/gcc/doc/standards.texi
+++ b/src/gcc/doc/standards.texi
@@ -288,6 +288,16 @@ a specific version. In general GCC trac
closely, and any given release will support the language as of the
date that the release was frozen.
+@section D language
+
+The D language is under development as of this writing; see the
+@uref{http://dlang.org/@/language-reference.html, current language
+reference}. At present the current major version of D is 2.0, and
+there is no way to describe the language supported by GCC in terms of
+a specific minor version. In general GCC follows the D frontend
+releases closely, and any given GCC release will support the current
+language as of the date that the release was frozen.
+
@section References for other languages
@xref{Top, GNAT Reference Manual, About This Guide, gnat_rm,
|