/usr/src/gcc-4.8/debian/patches/gdc-versym-os.diff is in gcc-4.8-source 4.8.2-19ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 | # DP: Implements D OS version conditions.
This implements the following official versions:
* Windows
** Win32
** Win64
** Cygwin
** MinGW
* linux
* OSX
* FreeBSD
* OpenBSD
* NetBSD
* Solaris
* Posix
* AIX
* SysV4
* Hurd
* Android
These gdc specific versions are also implemented:
* GNU_MinGW64 (for mingw-w64)
* GNU_OpenSolaris (for opensolaris)
* GNU_GLibc (implemented for linux & bsd & opensolaris)
* GNU_UCLibc (implemented for linux)
* GNU_Bionic (implemented for linux)
These official OS versions are not implemented:
* DragonFlyBSD
* BSD (other BSDs)
* Haiku
* SkyOS
* SysV3
Index: b/src/gcc/config/alpha/linux.h
===================================================================
--- a/src/gcc/config/alpha/linux.h
+++ b/src/gcc/config/alpha/linux.h
@@ -33,6 +33,16 @@
builtin_define ("_GNU_SOURCE"); \
} while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ if (OPTION_GLIBC) \
+ builtin_define ("GNU_GLibc"); \
+ \
+ builtin_define ("linux"); \
+ builtin_define ("Posix"); \
+ } while (0)
+
#undef LIB_SPEC
#define LIB_SPEC \
"%{pthread:-lpthread} \
Index: b/src/gcc/config/arm/linux-eabi.h
===================================================================
--- a/src/gcc/config/arm/linux-eabi.h
+++ b/src/gcc/config/arm/linux-eabi.h
@@ -30,6 +30,15 @@
} \
while (false)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ TARGET_GENERIC_LINUX_OS_D_BUILTINS(); \
+ ANDROID_TARGET_OS_D_BUILTINS(); \
+ } \
+ while (false)
+
/* We default to a soft-float ABI so that binaries can run on all
target hardware. If you override this to use the hard-float ABI then
change the setting of GLIBC_DYNAMIC_LINKER_DEFAULT as well. */
Index: b/src/gcc/config/darwin.h
===================================================================
--- a/src/gcc/config/darwin.h
+++ b/src/gcc/config/darwin.h
@@ -921,4 +921,10 @@
providing an osx-version-min of this unless overridden by the User. */
#define DEF_MIN_OSX_VERSION "10.4"
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ builtin_define ("OSX"); \
+ builtin_define ("Posix"); \
+ } while (0)
+
#endif /* CONFIG_DARWIN_H */
Index: b/src/gcc/config/freebsd.h
===================================================================
--- a/src/gcc/config/freebsd.h
+++ b/src/gcc/config/freebsd.h
@@ -32,6 +32,13 @@
#undef TARGET_OS_CPP_BUILTINS
#define TARGET_OS_CPP_BUILTINS() FBSD_TARGET_OS_CPP_BUILTINS()
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ builtin_define ("FreeBSD"); \
+ builtin_define ("Posix"); \
+ } while (0)
+
#undef CPP_SPEC
#define CPP_SPEC FBSD_CPP_SPEC
Index: b/src/gcc/config/gnu.h
===================================================================
--- a/src/gcc/config/gnu.h
+++ b/src/gcc/config/gnu.h
@@ -39,3 +39,11 @@
builtin_assert ("system=unix"); \
builtin_assert ("system=posix"); \
} while (0)
+
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ \
+ builtin_define ("Hurd"); \
+ builtin_define ("Posix"); \
+ } while (0)
Index: b/src/gcc/config/i386/cygwin.h
===================================================================
--- a/src/gcc/config/i386/cygwin.h
+++ b/src/gcc/config/i386/cygwin.h
@@ -20,6 +20,13 @@
#define EXTRA_OS_CPP_BUILTINS() /* Nothing. */
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ builtin_define ("Windows"); \
+ builtin_define ("Cygwin"); \
+ builtin_define ("Posix"); \
+ } while (0)
+
#undef CPP_SPEC
#define CPP_SPEC "%(cpp_cpu) %{posix:-D_POSIX_SOURCE} \
-D__CYGWIN32__ -D__CYGWIN__ %{!ansi:-Dunix} -D__unix__ -D__unix \
Index: b/src/gcc/config/i386/linux-common.h
===================================================================
--- a/src/gcc/config/i386/linux-common.h
+++ b/src/gcc/config/i386/linux-common.h
@@ -27,6 +27,15 @@
} \
while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ TARGET_GENERIC_LINUX_OS_D_BUILTINS(); \
+ ANDROID_TARGET_OS_D_BUILTINS(); \
+ } \
+ while (0)
+
#undef CC1_SPEC
#define CC1_SPEC \
LINUX_OR_ANDROID_CC (GNU_USER_TARGET_CC1_SPEC, \
Index: b/src/gcc/config/i386/mingw32.h
===================================================================
--- a/src/gcc/config/i386/mingw32.h
+++ b/src/gcc/config/i386/mingw32.h
@@ -53,6 +53,18 @@
} \
while (0)
+#define TARGET_OS_D_BUILTINS() TARGET_GENERIC_MINGW_OS_D_BUILTINS()
+#define TARGET_GENERIC_MINGW_OS_D_BUILTINS() \
+ do { \
+ builtin_define ("Windows"); \
+ builtin_define ("MinGW"); \
+ \
+ if (TARGET_64BIT && ix86_abi == MS_ABI) \
+ builtin_define ("Win64"); \
+ else if (!TARGET_64BIT) \
+ builtin_define ("Win32"); \
+ } while (0)
+
#ifndef TARGET_USE_PTHREAD_BY_DEFAULT
#define SPEC_PTHREAD1 "pthread"
#define SPEC_PTHREAD2 "!no-pthread"
Index: b/src/gcc/config/i386/mingw-w64.h
===================================================================
--- a/src/gcc/config/i386/mingw-w64.h
+++ b/src/gcc/config/i386/mingw-w64.h
@@ -84,3 +84,10 @@
%{static:-Bstatic} %{!static:-Bdynamic} \
%{shared|mdll: " SUB_LINK_ENTRY " --enable-auto-image-base} \
%(shared_libgcc_undefs)"
+
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ TARGET_GENERIC_MINGW_OS_D_BUILTINS(); \
+ builtin_define ("GNU_MinGW64"); \
+ } while (0)
Index: b/src/gcc/config/kfreebsd-gnu.h
===================================================================
--- a/src/gcc/config/kfreebsd-gnu.h
+++ b/src/gcc/config/kfreebsd-gnu.h
@@ -29,6 +29,14 @@
} \
while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ builtin_define ("FreeBSD"); \
+ builtin_define ("Posix"); \
+ builtin_define ("GNU_GLibc"); \
+ } while (0)
+
#define GNU_USER_DYNAMIC_LINKER GLIBC_DYNAMIC_LINKER
#define GNU_USER_DYNAMIC_LINKER32 GLIBC_DYNAMIC_LINKER32
#define GNU_USER_DYNAMIC_LINKER64 GLIBC_DYNAMIC_LINKER64
Index: b/src/gcc/config/knetbsd-gnu.h
===================================================================
--- a/src/gcc/config/knetbsd-gnu.h
+++ b/src/gcc/config/knetbsd-gnu.h
@@ -30,6 +30,16 @@
} \
while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ builtin_define ("NetBSD"); \
+ builtin_define ("Posix"); \
+ builtin_define ("GNU_GLibc"); \
+ } \
+ while (0)
+
#undef GNU_USER_DYNAMIC_LINKER
#define GNU_USER_DYNAMIC_LINKER "/lib/ld.so.1"
Index: b/src/gcc/config/kopensolaris-gnu.h
===================================================================
--- a/src/gcc/config/kopensolaris-gnu.h
+++ b/src/gcc/config/kopensolaris-gnu.h
@@ -30,5 +30,15 @@
} \
while (0)
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ builtin_define ("Solaris"); \
+ builtin_define ("Posix"); \
+ builtin_define ("GNU_OpenSolaris"); \
+ builtin_define ("GNU_GLibc"); \
+ } \
+ while (0)
+
#undef GNU_USER_DYNAMIC_LINKER
#define GNU_USER_DYNAMIC_LINKER "/lib/ld.so.1"
Index: b/src/gcc/config/linux-android.h
===================================================================
--- a/src/gcc/config/linux-android.h
+++ b/src/gcc/config/linux-android.h
@@ -25,6 +25,12 @@
builtin_define ("__ANDROID__"); \
} while (0)
+#define ANDROID_TARGET_OS_D_BUILTINS() \
+ do { \
+ if (TARGET_ANDROID) \
+ builtin_define ("Android"); \
+ } while (0)
+
#if ANDROID_DEFAULT
# define NOANDROID "mno-android"
#else
Index: b/src/gcc/config/linux.h
===================================================================
--- a/src/gcc/config/linux.h
+++ b/src/gcc/config/linux.h
@@ -49,6 +49,20 @@
builtin_assert ("system=posix"); \
} while (0)
+#define TARGET_OS_D_BUILTINS() TARGET_GENERIC_LINUX_OS_D_BUILTINS()
+#define TARGET_GENERIC_LINUX_OS_D_BUILTINS() \
+ do { \
+ if (OPTION_GLIBC) \
+ builtin_define ("GNU_GLibc"); \
+ else if (OPTION_UCLIBC) \
+ builtin_define ("GNU_UCLibc"); \
+ else if (OPTION_BIONIC) \
+ builtin_define ("GNU_Bionic"); \
+ \
+ builtin_define ("linux"); \
+ builtin_define ("Posix"); \
+ } while (0)
+
/* Determine which dynamic linker to use depending on whether GLIBC or
uClibc or Bionic is the default C library and whether
-muclibc or -mglibc or -mbionic has been passed to change the default. */
Index: b/src/gcc/config/mips/linux-common.h
===================================================================
--- a/src/gcc/config/mips/linux-common.h
+++ b/src/gcc/config/mips/linux-common.h
@@ -27,6 +27,15 @@
ANDROID_TARGET_OS_CPP_BUILTINS(); \
} while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ TARGET_GENERIC_LINUX_OS_D_BUILTINS(); \
+ ANDROID_TARGET_OS_D_BUILTINS(); \
+ } \
+ while (0)
+
#undef LINK_SPEC
#define LINK_SPEC \
LINUX_OR_ANDROID_LD (GNU_USER_TARGET_LINK_SPEC, \
Index: b/src/gcc/config/netbsd.h
===================================================================
--- a/src/gcc/config/netbsd.h
+++ b/src/gcc/config/netbsd.h
@@ -29,6 +29,14 @@
} \
while (0)
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ builtin_define ("NetBSD"); \
+ builtin_define ("Posix"); \
+ } \
+ while (0)
+
/* CPP_SPEC parts common to all NetBSD targets. */
#define NETBSD_CPP_SPEC \
"%{posix:-D_POSIX_SOURCE} \
Index: b/src/gcc/config/openbsd.h
===================================================================
--- a/src/gcc/config/openbsd.h
+++ b/src/gcc/config/openbsd.h
@@ -84,6 +84,14 @@
} \
while (0)
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ builtin_define ("OpenBSD"); \
+ builtin_define ("Posix"); \
+ } \
+ while (0)
+
/* TARGET_OS_CPP_BUILTINS() common to all OpenBSD ELF targets. */
#define OPENBSD_OS_CPP_BUILTINS_ELF() \
do \
Index: b/src/gcc/config/rs6000/aix.h
===================================================================
--- a/src/gcc/config/rs6000/aix.h
+++ b/src/gcc/config/rs6000/aix.h
@@ -110,6 +110,13 @@
} \
while (0)
+#define TARGET_OS_D_BUILTINS() \
+ do { \
+ \
+ builtin_define ("AIX"); \
+ builtin_define ("Posix"); \
+ } while (0)
+
/* Define appropriate architecture macros for preprocessor depending on
target switches. */
Index: b/src/gcc/config/rs6000/linux64.h
===================================================================
--- a/src/gcc/config/rs6000/linux64.h
+++ b/src/gcc/config/rs6000/linux64.h
@@ -323,6 +323,17 @@
} \
while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ builtin_define ("linux"); \
+ builtin_define ("Posix"); \
+ if (OPTION_GLIBC) \
+ builtin_define ("GNU_GLibc"); \
+ } \
+ while (0)
+
#undef CPP_OS_DEFAULT_SPEC
#define CPP_OS_DEFAULT_SPEC "%(cpp_os_linux)"
Index: b/src/gcc/config/rs6000/linux.h
===================================================================
--- a/src/gcc/config/rs6000/linux.h
+++ b/src/gcc/config/rs6000/linux.h
@@ -52,6 +52,17 @@
} \
while (0)
+#undef TARGET_OS_D_BUILTINS
+#define TARGET_OS_D_BUILTINS() \
+ do \
+ { \
+ builtin_define ("linux"); \
+ builtin_define ("Posix"); \
+ if (OPTION_GLIBC) \
+ builtin_define ("GNU_GLibc"); \
+ } \
+ while (0)
+
#undef CPP_OS_DEFAULT_SPEC
#define CPP_OS_DEFAULT_SPEC "%(cpp_os_linux)"
|