/usr/src/gcc-4.8/debian/patches/libgcc-no-limits-h.diff is in gcc-4.8-source 4.8.2-19ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 | # DP: Don't include <limits.h> in libgcc/libgcc2.c.
2013-07-15 Matthias Klose <doko@ubuntu.com>
* libgcc2.c: Don't include <limits.h>.
Index: libgcc/libgcc2.c
===================================================================
--- a/src/libgcc/libgcc2.c (revision 198927)
+++ b/src/libgcc/libgcc2.c (working copy)
@@ -1674,18 +1674,6 @@
#endif
#if defined(L_fixunsxfsi) && LIBGCC2_HAS_XF_MODE
-/* Reenable the normal types, in case limits.h needs them. */
-#undef char
-#undef short
-#undef int
-#undef long
-#undef unsigned
-#undef float
-#undef double
-#undef MIN
-#undef MAX
-#include <limits.h>
-
UWtype
__fixunsxfSI (XFtype a)
{
@@ -1696,18 +1684,6 @@
#endif
#if defined(L_fixunsdfsi) && LIBGCC2_HAS_DF_MODE
-/* Reenable the normal types, in case limits.h needs them. */
-#undef char
-#undef short
-#undef int
-#undef long
-#undef unsigned
-#undef float
-#undef double
-#undef MIN
-#undef MAX
-#include <limits.h>
-
UWtype
__fixunsdfSI (DFtype a)
{
@@ -1718,18 +1694,6 @@
#endif
#if defined(L_fixunssfsi) && LIBGCC2_HAS_SF_MODE
-/* Reenable the normal types, in case limits.h needs them. */
-#undef char
-#undef short
-#undef int
-#undef long
-#undef unsigned
-#undef float
-#undef double
-#undef MIN
-#undef MAX
-#include <limits.h>
-
UWtype
__fixunssfSI (SFtype a)
{
|