/usr/src/gcc-4.8/debian/rules.d/binary-d.mk is in gcc-4.8-source 4.8.2-19ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 | arch_binaries := $(arch_binaries) gdc
ifeq ($(with_libphobos),yes)
arch_binaries += libphobos-dev
endif
p_gdc = gdc$(pkg_ver)$(cross_bin_arch)
p_libphobos = libphobos$(pkg_ver)-dev
d_gdc = debian/$(p_gdc)
d_libphobos = debian/$(p_libphobos)
gdc_include_dir := $(PF)/include/d
dirs_gdc = \
$(PF)/bin \
$(PF)/share/man/man1 \
$(gcc_lexec_dir)
ifneq ($(DEB_CROSS),yes)
dirs_gdc += \
$(gdc_include_dir)/$(BASE_VERSION)
endif
files_gdc = \
$(PF)/bin/$(cmd_prefix)gdc$(pkg_ver) \
$(gcc_lexec_dir)/cc1d
ifneq ($(GFDL_INVARIANT_FREE),yes-now-pure-gfdl)
files_gdc += \
$(PF)/share/man/man1/$(cmd_prefix)gdc$(pkg_ver).1
endif
dirs_libphobos = \
$(PF)/lib \
$(gdc_include_dir)/$(BASE_VERSION) \
$(gcc_lib_dir)
files_libphobos = \
$(PF)/$(libdir)/libgphobos2.a \
$(gdc_include_dir)/$(BASE_VERSION)
$(binary_stamp)-gdc: $(install_stamp)
dh_testdir
dh_testroot
mv $(install_stamp) $(install_stamp)-tmp
rm -rf $(d_gdc)
dh_installdirs -p$(p_gdc) $(dirs_gdc)
dh_installdocs -p$(p_gdc) src/gcc/d/README
dh_installchangelogs -p$(p_gdc) src/gcc/d/ChangeLog
DH_COMPAT=2 dh_movefiles -p$(p_gdc) -X/zlib/ $(files_gdc)
ifneq ($(DEB_CROSS),yes)
ln -sf gdc$(pkg_ver) \
$(d_gdc)/$(PF)/bin/$(DEB_TARGET_GNU_TYPE)-gdc$(pkg_ver)
ln -sf gdc$(pkg_ver) \
$(d_gdc)/$(PF)/bin/$(TARGET_ALIAS)-gdc$(pkg_ver)
ifneq ($(GFDL_INVARIANT_FREE),yes-now-pure-gfdl)
ln -sf gdc$(pkg_ver).1 \
$(d_gdc)/$(PF)/share/man/man1/$(DEB_TARGET_GNU_TYPE)-gdc$(pkg_ver).1
ln -sf gdc$(pkg_ver).1 \
$(d_gdc)/$(PF)/share/man/man1/$(TARGET_ALIAS)-gdc$(pkg_ver).1
endif
endif
# FIXME: object.di needs to go into a libgdc-dev Multi-Arch: same package
ifneq ($(DEB_CROSS),yes)
# Always needed by gdc.
cp $(srcdir)/libphobos/libdruntime/object.di \
$(d_gdc)/$(gdc_include_dir)/$(BASE_VERSION)/.
dh_link -p$(p_gdc) \
/$(gdc_include_dir)/$(BASE_VERSION) \
/$(gdc_include_dir)/$(GCC_VERSION)
endif
dh_link -p$(p_gdc) \
/$(docdir)/$(p_gcc)/README.Bugs \
/$(docdir)/$(p_gdc)/README.Bugs
dh_strip -p$(p_gdc)
dh_compress -p$(p_gdc)
dh_fixperms -p$(p_gdc)
dh_shlibdeps -p$(p_gdc)
dh_gencontrol -p$(p_gdc) -- -v$(DEB_GDC_VERSION) $(common_substvars)
dh_installdeb -p$(p_gdc)
dh_md5sums -p$(p_gdc)
dh_builddeb -p$(p_gdc)
find $(d_gdc) -type d -empty -delete
trap '' 1 2 3 15; touch $@; mv $(install_stamp)-tmp $(install_stamp)
$(binary_stamp)-libphobos: $(install_stamp)
dh_testdir
dh_testroot
mv $(install_stamp) $(install_stamp)-tmp
rm -rf $(d_libphobos)
dh_installdirs -p$(p_libphobos) $(dirs_libphobos)
DH_COMPAT=2 dh_movefiles -p$(p_libphobos) $(files_libphobos)
# better to have it there, avoid conflicts
mv $(d_libphobos)/$(PF)/$(libdir)/libgphobos2.a \
$(d_libphobos)/$(gcc_lib_dir)
# included in gdc package
rm -f $(d_libphobos)/$(gdc_include_dir)/$(BASE_VERSION)/object.di
ifeq ($(with_separate_gdc),yes)
debian/dh_doclink -p$(p_libphobos) $(p_gdc)
else
debian/dh_doclink -p$(p_libphobos) $(p_base)
endif
dh_strip -p$(p_libphobos)
dh_compress -p$(p_libphobos)
dh_fixperms -p$(p_libphobos)
dh_shlibdeps -p$(p_libphobos)
dh_gencontrol -p$(p_libphobos) -- -v$(DEB_GDC_VERSION) $(common_substvars)
dh_installdeb -p$(p_libphobos)
dh_md5sums -p$(p_libphobos)
dh_builddeb -p$(p_libphobos)
find $(d_libphobos) -type d -empty -delete
trap '' 1 2 3 15; touch $@; mv $(install_stamp)-tmp $(install_stamp)
define __do_libphobos_dev
dh_testdir
dh_testroot
mv $(install_stamp) $(install_stamp)-tmp
rm -rf $(d_l)
dh_installdirs -p$(p_l) \
$(gcc_lib_dir$(2))
DH_COMPAT=2 dh_movefiles -p$(p_l) \
$(files_libphobos)
: # better to have it there, avoid conflicts
mv $(d_l)/$(PF)/$(libdir)/libgphobos2.a \
$(d_l)/$(gcc_lib_dir)
: # included in gdc package
rm -f $(d_l)/$(gdc_include_dir)/$(BASE_VERSION)/object.di
debian/dh_doclink -p$(p_l) \
$(if $(filter yes,$(with_separate_gdc)),$(p_gdc),$(p_base))
dh_compress -p$(p_l)
dh_fixperms -p$(p_l)
$(cross_gencontrol) dh_gencontrol -p$(p_l) \
-- -v$(DEB_VERSION) $(common_substvars)
$(call cross_mangle_control,$(p_l))
dh_installdeb -p$(p_l)
dh_md5sums -p$(p_l)
dh_builddeb -p$(p_l)
trap '' 1 2 3 15; touch $@; mv $(install_stamp)-tmp $(install_stamp)
endef
# don't put this as a comment within define/endef
# $(call install_gcc_lib,libphobos,$(PHOBOS_SONAME),$(2),$(p_l))
do_libphobos_dev = $(call __do_libphobos_dev,lib$(1)phobos-$(BASE_VERSION)-dev,$(1))
$(binary_stamp)-libphobos-dev: $(install_stamp)
$(call do_libphobos_dev,)
|