/usr/src/gcc-4.4/debian/patches/ada-gnatvsn.diff is in gcc-4.4-source 4.4.7-8ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 | # DP: proposed patch for PR ada/27194.
--- a/src/gcc/gnatvsn.adb.orig 2005-07-01 03:29:17.000000000 +0200
+++ b/src/gcc/ada/gnatvsn.adb 2006-04-18 10:00:05.100002000 +0200
@@ -54,12 +54,13 @@
---/----------------------
function Gnat_Version_String return String is
- NUL_Pos : Positive := 1;
+ NUL_Pos : Positive := Version_String'Last;
begin
- loop
- exit when Version_String (NUL_Pos) = ASCII.NUL;
-
- NUL_Pos := NUL_Pos + 1;
+ for J in Version_String'Range loop
+ if Version_String (J) = ASCII.NUL then
+ NUL_Pos := J;
+ exit;
+ end if;
end loop;
return Version_String (1 .. NUL_Pos - 1);
|