/usr/src/gcc-4.7/debian/patches/ada-nobiarch-check.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | # DP: For biarch builds, disable the gnat testsuite for the non-default
# architecture (no biarch support in gnat yet).
Index: b/src/gcc/Makefile.in
===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
@@ -4510,7 +4510,11 @@
if [ -f $${rootme}/../expect/expect ] ; then \
TCL_LIBRARY=`cd .. ; cd $${srcdir}/../tcl/library ; ${PWD_COMMAND}` ; \
export TCL_LIBRARY ; fi ; \
- $(RUNTEST) --tool $* $(RUNTESTFLAGS))
+ if [ "$*" = gnat ]; then \
+ runtestflags="`echo '$(RUNTESTFLAGS)' | sed 's/,-m[36][24]//;s/,-mabi=n32//'`"; \
+ case "$$runtestflags" in *\\{\\}) runtestflags=; esac; \
+ fi; \
+ $(RUNTEST) --tool $* $$runtestflags)
$(patsubst %,%-subtargets,$(filter-out $(lang_checks_parallelized),$(lang_checks))): check-%-subtargets:
@echo check-$*
|