/usr/src/gcc-4.7/debian/patches/alpha-ieee.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 | # DP: #212912
# DP: on alpha-linux, make -mieee default and add -mieee-disable switch
# DP: to turn default off
---
gcc/config/alpha/alpha.c | 4 ++++
1 files changed, 4 insertions(+), 0 deletions(-)
--- a/src/gcc/config/alpha/alpha.c
+++ b/src/gcc/config/alpha/alpha.c
@@ -246,6 +246,10 @@
int const ct_size = ARRAY_SIZE (cpu_table);
int i;
+ /* If not -ffinite-math-only, enable -mieee*/
+ if (!flag_finite_math_only)
+ target_flags |= MASK_IEEE|MASK_IEEE_CONFORMANT;
+
#ifdef SUBTARGET_OVERRIDE_OPTIONS
SUBTARGET_OVERRIDE_OPTIONS;
#endif
|