/usr/src/gcc-4.7/debian/patches/cross-fixes.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 | # DP: Fix the linker error when creating an xcc for ia64
---
gcc/config/ia64/fde-glibc.c | 3 +++
gcc/config/ia64/unwind-ia64.c | 3 ++-
gcc/unwind-compat.c | 2 ++
gcc/unwind-generic.h | 2 ++
6 files changed, 14 insertions(+), 1 deletions(-)
Index: b/src/libgcc/config/ia64/fde-glibc.c
===================================================================
--- a/src/libgcc/config/ia64/fde-glibc.c
+++ b/src/libgcc/config/ia64/fde-glibc.c
@@ -28,6 +28,7 @@
#ifndef _GNU_SOURCE
#define _GNU_SOURCE 1
#endif
+#ifndef inhibit_libc
#include "config.h"
#include <stddef.h>
#include <stdlib.h>
@@ -160,3 +161,5 @@
return data.ret;
}
+
+#endif
Index: b/src/libgcc/config/ia64/unwind-ia64.c
===================================================================
--- a/src/libgcc/config/ia64/unwind-ia64.c
+++ b/src/libgcc/config/ia64/unwind-ia64.c
@@ -27,6 +27,7 @@
see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
<http://www.gnu.org/licenses/>. */
+#ifndef inhibit_libc
#include "tconfig.h"
#include "tsystem.h"
#include "coretypes.h"
@@ -2469,3 +2470,4 @@
#endif
#endif
+#endif
Index: b/src/libgcc/unwind-compat.c
===================================================================
--- a/src/libgcc/unwind-compat.c
+++ b/src/libgcc/unwind-compat.c
@@ -24,6 +24,7 @@
<http://www.gnu.org/licenses/>. */
#if defined (USE_GAS_SYMVER) && defined (USE_LIBUNWIND_EXCEPTIONS)
+#ifndef inhibit_libc
#include "tconfig.h"
#include "tsystem.h"
#include "unwind.h"
@@ -208,3 +209,4 @@
}
symver (_Unwind_SetIP, GCC_3.0);
#endif
+#endif
Index: b/src/libgcc/unwind-generic.h
===================================================================
--- a/src/libgcc/unwind-generic.h
+++ b/src/libgcc/unwind-generic.h
@@ -211,6 +211,7 @@
compatible with the standard ABI for IA-64, we inline these. */
#ifdef __ia64__
+#ifndef inhibit_libc
#include <stdlib.h>
static inline _Unwind_Ptr
@@ -229,6 +230,7 @@
/* @@@ Retrieve the Backing Store Pointer of the given context. */
extern _Unwind_Word _Unwind_GetBSP (struct _Unwind_Context *);
+#endif
#else
extern _Unwind_Ptr _Unwind_GetDataRelBase (struct _Unwind_Context *);
extern _Unwind_Ptr _Unwind_GetTextRelBase (struct _Unwind_Context *);
|