/usr/src/gcc-4.7/debian/patches/libgo-setcontext-config.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | # DP: libgo: Overwrite the setcontext_clobbers_tls check on mips*
--- a/src/libgo/configure.ac
+++ b/src/libgo/configure.ac
@@ -752,7 +752,15 @@
CFLAGS="$CFLAGS_hold"
LIBS="$LIBS_hold"
])
+dnl overwrite for the mips* 64bit multilibs, fails on some buildds
if test "$libgo_cv_lib_setcontext_clobbers_tls" = "yes"; then
+ case "$target" in
+ mips*-linux-*)
+ AC_MSG_WARN([FIXME: overwrite setcontext_clobbers_tls for $target:$ptr_type_size])
+ libgo_cv_lib_setcontext_clobbers_tls=no ;;
+ esac
+fi
+if test "$libgo_cv_lib_setcontext_clobbers_tls" = "yes"; then
AC_DEFINE(SETCONTEXT_CLOBBERS_TLS, 1,
[Define if setcontext clobbers TLS variables])
fi
|