/usr/src/gcc-4.7/debian/patches/libgomp-kfreebsd-testsuite.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 | # DP: Disable lock-2.c test on kfreebsd-*
--- a/src/libgomp/testsuite/libgomp.c/lock-2.c
+++ b/src/libgomp/testsuite/libgomp.c/lock-2.c
@@ -4,6 +4,9 @@
int
main (void)
{
+#ifdef __FreeBSD_kernel__
+ return 1;
+#endif
int l = 0;
omp_nest_lock_t lock;
omp_init_nest_lock (&lock);
|