/usr/src/gcc-4.7/debian/patches/pr45078.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 | # DP: Proposed patch for PR plugin/45078
2011-06-24 Matthias Klose <doko@ubuntu.com>
PR plugin/45078
* Makefile.in (PLUGIN_HEADERS): Add config/arm/arm-cores.def.
(install-plugin): Install c-family headers into a c-family subdir.
* config.gcc: Add vxworks-dummy.h to tm_file for arm, mips, sh and
sparc targets.
Index: b/src/gcc/Makefile.in
===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
@@ -4570,6 +4570,7 @@
$(C_PRAGMA_H) $(CPPLIB_H) $(FUNCTION_H) \
cppdefault.h flags.h $(MD5_H) params.def params.h prefix.h tree-inline.h \
gimple-pretty-print.h tree-pretty-print.h realmpfr.h \
+ config/arm/arm-cores.def \
$(IPA_PROP_H) $(RTL_H) $(TM_P_H) $(CFGLOOP_H) $(EMIT_RTL_H) version.h
# generate the 'build fragment' b-header-vars
Index: b/src/gcc/config.gcc
===================================================================
--- a/src/gcc/config.gcc
+++ b/src/gcc/config.gcc
@@ -533,6 +533,9 @@
fi
tm_file="vxworks-dummy.h ${tm_file}"
;;
+arm*-*-*|mips*-*-*|sh*-*-*|sparc*-*-*)
+ tm_file="vxworks-dummy.h ${tm_file}"
+ ;;
esac
# On a.out targets, we need to use collect2.
|