/usr/src/gcc-4.7/debian/patches/rename-info-files.diff is in gcc-4.7-source 4.7.3-12ubuntu1.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826 827 828 829 830 831 832 833 834 835 836 837 838 839 840 | # DP: Allow transformations on info file names. Reference the
# DP: transformed info file names in the texinfo files.
2004-02-17 Matthias Klose <doko@debian.org>
gcc/ChangeLog:
* Makefile.in: Allow transformations on info file names.
Define MAKEINFODEFS, macros to pass transformated info file
names to makeinfo.
* doc/cpp.texi: Use macros defined in MAKEINFODEFS for references.
* doc/cppinternals.texi: Likewise.
* doc/extend.texi: Likewise.
* doc/gcc.texi: Likewise.
* doc/gccint.texi: Likewise.
* doc/invoke.texi: Likewise.
* doc/libgcc.texi: Likewise.
* doc/makefile.texi: Likewise.
* doc/passes.texi: Likewise.
* doc/sourcebuild.texi: Likewise.
* doc/standards.texi: Likewise.
* doc/trouble.texi: Likewise.
gcc/fortran/ChangeLog:
* Make-lang.in: Allow transformations on info file names.
Pass macros of transformated info file defined in MAKEINFODEFS
names to makeinfo.
* gfortran.texi: Use macros defined in MAKEINFODEFS for references.
gcc/java/ChangeLog:
* Make-lang.in: Allow transformations on info file names.
Pass macros of transformated info file defined in MAKEINFODEFS
Index: b/src/gcc/fortran/gfortran.texi
===================================================================
--- a/src/gcc/fortran/gfortran.texi
+++ b/src/gcc/fortran/gfortran.texi
@@ -101,7 +101,7 @@
@ifinfo
@dircategory Software development
@direntry
-* gfortran: (gfortran). The GNU Fortran Compiler.
+* @value{fngfortran}: (@value{fngfortran}). The GNU Fortran Compiler.
@end direntry
This file documents the use and the internals of
the GNU Fortran compiler, (@command{gfortran}).
Index: b/src/gcc/fortran/Make-lang.in
===================================================================
--- a/src/gcc/fortran/Make-lang.in
+++ b/src/gcc/fortran/Make-lang.in
@@ -118,7 +118,8 @@
cd $(srcdir)/fortran; etags -o TAGS.sub *.c *.h; \
etags --include TAGS.sub --include ../TAGS.sub
-fortran.info: doc/gfortran.info doc/gfc-internals.info
+INFO_FORTRAN_NAME = $(shell echo gfortran|sed '$(program_transform_name)')
+fortran.info: doc/$(INFO_FORTRAN_NAME).info
fortran.dvi: doc/gfortran.dvi doc/gfc-internals.dvi
F95_HTMLFILES = $(build_htmldir)/gfortran
@@ -190,10 +191,10 @@
$(srcdir)/doc/include/gcc-common.texi \
gcc-vers.texi
-doc/gfortran.info: $(GFORTRAN_TEXI)
+doc/$(INFO_FORTRAN_NAME).info: $(GFORTRAN_TEXI)
if [ x$(BUILD_INFO) = xinfo ]; then \
rm -f doc/gfortran.info-*; \
- $(MAKEINFO) -I $(srcdir)/doc/include -I $(srcdir)/fortran \
+ $(MAKEINFO) $(MAKEINFODEFS) -I $(srcdir)/doc/include -I $(srcdir)/fortran \
-o $@ $<; \
else true; fi
@@ -261,7 +262,7 @@
fortran.install-plugin:
-fortran.install-info: $(DESTDIR)$(infodir)/gfortran.info
+fortran.install-info: $(DESTDIR)$(infodir)/$(INFO_FORTRAN_NAME).info
fortran.install-man: $(DESTDIR)$(man1dir)/$(GFORTRAN_INSTALL_NAME)$(man1ext)
@@ -279,7 +280,7 @@
rm -rf $(DESTDIR)$(bindir)/$(GFORTRAN_INSTALL_NAME)$(exeext); \
rm -rf $(DESTDIR)$(man1dir)/$(GFORTRAN_INSTALL_NAME)$(man1ext); \
rm -rf $(DESTDIR)$(bindir)/$(GFORTRAN_TARGET_INSTALL_NAME)$(exeext); \
- rm -rf $(DESTDIR)$(infodir)/gfortran.info*
+ rm -rf $(DESTDIR)$(infodir)/$(INFO_FORTRAN_NAME).info*
#
# Clean hooks:
Index: b/src/gcc/Makefile.in
===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
@@ -4258,8 +4258,30 @@
doc: $(BUILD_INFO) $(GENERATED_MANPAGES)
-INFOFILES = doc/cpp.info doc/gcc.info doc/gccint.info \
- doc/gccinstall.info doc/cppinternals.info
+INFO_CPP_NAME = $(shell echo cpp|sed '$(program_transform_name)')
+INFO_GCC_NAME = $(shell echo gcc|sed '$(program_transform_name)')
+INFO_GXX_NAME = $(shell echo g++|sed '$(program_transform_name)')
+INFO_GCCINT_NAME = $(shell echo gccint|sed '$(program_transform_name)')
+INFO_GCCINSTALL_NAME = $(shell echo gccinstall|sed '$(program_transform_name)')
+INFO_CPPINT_NAME = $(shell echo cppinternals|sed '$(program_transform_name)')
+
+INFO_FORTRAN_NAME = $(shell echo gfortran|sed '$(program_transform_name)')
+INFO_GCJ_NAME = $(shell echo gcj|sed '$(program_transform_name)')
+INFO_GCCGO_NAME = $(shell echo gccgo|sed '$(program_transform_name)')
+
+INFOFILES = doc/$(INFO_CPP_NAME).info doc/$(INFO_GCC_NAME).info \
+ doc/$(INFO_GCCINT_NAME).info \
+ doc/$(INFO_GCCINSTALL_NAME).info doc/$(INFO_CPPINT_NAME).info
+
+MAKEINFODEFS = -D 'fncpp $(INFO_CPP_NAME)' \
+ -D 'fngcc $(INFO_GCC_NAME)' \
+ -D 'fngxx $(INFO_GXX_NAME)' \
+ -D 'fngccint $(INFO_GCCINT_NAME)' \
+ -D 'fngccinstall $(INFO_GCCINSTALL_NAME)' \
+ -D 'fncppint $(INFO_CPPINT_NAME)' \
+ -D 'fngfortran $(INFO_FORTRAN_NAME)' \
+ -D 'fngcj $(INFO_GCJ_NAME)' \
+ -D 'fngccgo $(INFO_GCCGO_NAME)'
info: $(INFOFILES) lang.info @GENINSRC@ srcinfo lang.srcinfo
@@ -4305,7 +4327,19 @@
if [ -n "$(PKGVERSION)" ]; then \
echo "@set VERSION_PACKAGE $(PKGVERSION)" >> $@T; \
fi
- echo "@set BUGURL $(BUGURL_TEXI)" >> $@T; \
+ echo "@set BUGURL $(BUGURL_TEXI)" >> $@T
+ ( \
+ echo '@set fncpp $(INFO_CPP_NAME)'; \
+ echo '@set fngcc $(INFO_GCC_NAME)'; \
+ echo '@set fngcov $(INFO_GCC_NAME)'; \
+ echo '@set fngxx $(INFO_GXX_NAME)'; \
+ echo '@set fngccint $(INFO_GCCINT_NAME)'; \
+ echo '@set fngccinstall $(INFO_GCCINSTALL_NAME)'; \
+ echo '@set fncppint $(INFO_CPPINT_NAME)'; \
+ echo '@set fngfortran $(INFO_FORTRAN_NAME)'; \
+ echo '@set fngcj $(INFO_GCJ_NAME)'; \
+ echo '@set fngccgo $(INFO_GCCGO_NAME)'; \
+ ) >> $@T
mv -f $@T $@
@@ -4313,21 +4347,41 @@
# patterns. To use them, put each of the specific targets with its
# specific dependencies but no build commands.
-doc/cpp.info: $(TEXI_CPP_FILES)
-doc/gcc.info: $(TEXI_GCC_FILES)
-doc/gccint.info: $(TEXI_GCCINT_FILES)
-doc/cppinternals.info: $(TEXI_CPPINT_FILES)
-
+# Generic entry to handle info files, which are not renamed (currently Ada)
doc/%.info: %.texi
if [ x$(BUILD_INFO) = xinfo ]; then \
$(MAKEINFO) $(MAKEINFOFLAGS) -I . -I $(gcc_docdir) \
-I $(gcc_docdir)/include -o $@ $<; \
fi
+doc/$(INFO_CPP_NAME).info: $(TEXI_CPP_FILES)
+ if [ x$(BUILD_INFO) = xinfo ]; then \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
+ -I $(gcc_docdir)/include -o $@ $<; \
+ fi
+
+doc/$(INFO_GCC_NAME).info: $(TEXI_GCC_FILES)
+ if [ x$(BUILD_INFO) = xinfo ]; then \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
+ -I $(gcc_docdir)/include -o $@ $<; \
+ fi
+
+doc/$(INFO_GCCINT_NAME).info: $(TEXI_GCCINT_FILES)
+ if [ x$(BUILD_INFO) = xinfo ]; then \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
+ -I $(gcc_docdir)/include -o $@ $<; \
+ fi
+
+doc/$(INFO_CPPINT_NAME).info: $(TEXI_CPPINT_FILES)
+ if [ x$(BUILD_INFO) = xinfo ]; then \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
+ -I $(gcc_docdir)/include -o $@ $<; \
+ fi
+
# Duplicate entry to handle renaming of gccinstall.info
-doc/gccinstall.info: $(TEXI_GCCINSTALL_FILES)
+doc/$(INFO_GCCINSTALL_NAME).info: $(TEXI_GCCINSTALL_FILES)
if [ x$(BUILD_INFO) = xinfo ]; then \
- $(MAKEINFO) $(MAKEINFOFLAGS) -I $(gcc_docdir) \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
-I $(gcc_docdir)/include -o $@ $<; \
fi
@@ -4688,11 +4742,11 @@
# $(INSTALL_DATA) might be a relative pathname, so we can't cd into srcdir
# to do the install.
install-info:: doc installdirs \
- $(DESTDIR)$(infodir)/cpp.info \
- $(DESTDIR)$(infodir)/gcc.info \
- $(DESTDIR)$(infodir)/cppinternals.info \
- $(DESTDIR)$(infodir)/gccinstall.info \
- $(DESTDIR)$(infodir)/gccint.info \
+ $(DESTDIR)$(infodir)/$(INFO_CPP_NAME).info \
+ $(DESTDIR)$(infodir)/$(INFO_GCC_NAME).info \
+ $(DESTDIR)$(infodir)/$(INFO_CPPINT_NAME).info \
+ $(DESTDIR)$(infodir)/$(INFO_GCCINSTALL_NAME).info \
+ $(DESTDIR)$(infodir)/$(INFO_GCCINT_NAME).info \
lang.install-info
$(DESTDIR)$(infodir)/%.info: doc/%.info installdirs
@@ -4899,8 +4953,11 @@
-rm -rf $(DESTDIR)$(bindir)/$(GCOV_INSTALL_NAME)$(exeext)
-rm -rf $(DESTDIR)$(man1dir)/$(GCC_INSTALL_NAME)$(man1ext)
-rm -rf $(DESTDIR)$(man1dir)/cpp$(man1ext)
- -rm -f $(DESTDIR)$(infodir)/cpp.info* $(DESTDIR)$(infodir)/gcc.info*
- -rm -f $(DESTDIR)$(infodir)/cppinternals.info* $(DESTDIR)$(infodir)/gccint.info*
+ -rm -f $(DESTDIR)$(infodir)/$(INFO_CPP_NAME).info*
+ -rm -f $(DESTDIR)$(infodir)/$(INFO_GCC_NAME).info*
+ -rm -f $(DESTDIR)$(infodir)/$(INFO_CPPINT_NAME).info*
+ -rm -f $(DESTDIR)$(infodir)/$(INFO_GCCINT_NAME).info*
+ -rm -f $(DESTDIR)$(infodir)/$(INFO_GCCINSTALL_NAME).info*
for i in ar nm ranlib ; do \
install_name=`echo gcc-$$i|sed '$(program_transform_name)'`$(exeext) ;\
target_install_name=$(target_noncanonical)-`echo gcc-$$i|sed '$(program_transform_name)'`$(exeext) ; \
Index: b/src/gcc/java/gcj.texi
===================================================================
--- a/src/gcc/java/gcj.texi
+++ b/src/gcc/java/gcj.texi
@@ -55,25 +55,25 @@
@format
@dircategory Software development
@direntry
-* Gcj: (gcj). Ahead-of-time compiler for the Java language
+* @value{fngcj}: (@value{fngcj}). Ahead-of-time compiler for the Java language
@end direntry
@dircategory Individual utilities
@direntry
-* jcf-dump: (gcj)Invoking jcf-dump.
+* jcf-dump: (@value{fngcj}) Invoking jcf-dump.
Print information about Java class files
-* gij: (gcj)Invoking gij. GNU interpreter for Java bytecode
-* gcj-dbtool: (gcj)Invoking gcj-dbtool.
+* gij: (@value{fngcj}) Invoking gij. GNU interpreter for Java bytecode
+* gcj-dbtool: (@value{fngcj}) Invoking gcj-dbtool.
Tool for manipulating class file databases.
-* jv-convert: (gcj)Invoking jv-convert.
+* jv-convert: (@value{fngcj}) Invoking jv-convert.
Convert file from one encoding to another
-* grmic: (gcj)Invoking grmic.
+* grmic: (@value{fngcj}) Invoking grmic.
Generate stubs for Remote Method Invocation.
-* gc-analyze: (gcj)Invoking gc-analyze.
+* gc-analyze: (@value{fngcj}) Invoking gc-analyze.
Analyze Garbage Collector (GC) memory dumps.
-* aot-compile: (gcj)Invoking aot-compile.
+* aot-compile: (@value{fngcj})Invoking aot-compile.
Compile bytecode to native and generate databases.
-* rebuild-gcj-db: (gcj)Invoking rebuild-gcj-db.
+* rebuild-gcj-db: (@value{fngcj})Invoking rebuild-gcj-db.
Merge the per-solib databases made by aot-compile
into one system-wide database.
@end direntry
@@ -159,7 +159,7 @@
As @command{gcj} is just another front end to @command{gcc}, it supports many
of the same options as gcc. @xref{Option Summary, , Option Summary,
-gcc, Using the GNU Compiler Collection (GCC)}. This manual only documents the
+@value{fngcc}, Using the GNU Compiler Collection (GCC)}. This manual only documents the
options specific to @command{gcj}.
@c man end
Index: b/src/gcc/java/Make-lang.in
===================================================================
--- a/src/gcc/java/Make-lang.in
+++ b/src/gcc/java/Make-lang.in
@@ -127,11 +127,23 @@
etags --include TAGS.sub --include ../TAGS.sub
-java.info: doc/gcj.info
+TEXI_GCJ_FILES = java/gcj.texi \
+ $(gcc_docdir)/include/gpl.texi $(gcc_docdir)/include/funding.texi \
+ $(gcc_docdir)/include/fdl.texi $(gcc_docdir)/include/gcc-common.texi gcc-vers.texi
+INFO_GCJ_NAME = $(shell echo gcj|sed '$(program_transform_name)')
-java.srcinfo: doc/gcj.info
+java.info: doc/$(INFO_GCJ_NAME).info
+
+java.srcinfo: doc/$(INFO_GCJ_NAME).info
-cp -p $^ $(srcdir)/doc
+doc/$(INFO_GCJ_NAME).info: $(TEXI_GCJ_FILES)
+ if test "x$(BUILD_INFO)" = xinfo; then \
+ rm -f $(@)*; \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) \
+ -I$(gcc_docdir)/include -I$(srcdir)/f -o$@ $<; \
+ fi
+
java.dvi: doc/gcj.dvi
JAVA_PDFFILES = doc/gcj.pdf
@@ -195,7 +207,7 @@
-rm -rf $(DESTDIR)$(man1dir)/aot-compile$(man1ext)
-rm -rf $(DESTDIR)$(man1dir)/rebuild-gcj-db$(man1ext)
-java.install-info: $(DESTDIR)$(infodir)/gcj.info
+java.install-info: $(DESTDIR)$(infodir)/$(INFO_GCJ_NAME).info
java.install-pdf: $(JAVA_PDFFILES)
@$(NORMAL_INSTALL)
Index: b/src/gcc/ada/gnat-style.texi
===================================================================
--- a/src/gcc/ada/gnat-style.texi
+++ b/src/gcc/ada/gnat-style.texi
@@ -31,7 +31,7 @@
@dircategory Software development
@direntry
-* gnat-style: (gnat-style). GNAT Coding Style
+* gnat-style: (gnat-style-4.7). GNAT Coding Style
@end direntry
@macro syntax{element}
Index: b/src/gcc/ada/gnat_rm.texi
===================================================================
--- a/src/gcc/ada/gnat_rm.texi
+++ b/src/gcc/ada/gnat_rm.texi
@@ -38,7 +38,7 @@
@dircategory GNU Ada tools
@direntry
-* GNAT Reference Manual: (gnat_rm). Reference Manual for GNU Ada tools.
+* GNAT Reference Manual: (gnat_rm-4.7). Reference Manual for GNU Ada tools.
@end direntry
@titlepage
Index: b/src/gcc/doc/invoke.texi
===================================================================
--- a/src/gcc/doc/invoke.texi
+++ b/src/gcc/doc/invoke.texi
@@ -9442,7 +9442,7 @@
@option{-nodefaultlibs} is @file{libgcc.a}, a library of internal subroutines
which GCC uses to overcome shortcomings of particular machines, or special
needs for some languages.
-(@xref{Interface,,Interfacing to GCC Output,gccint,GNU Compiler
+(@xref{Interface,,Interfacing to GCC Output,@value{fngccint},GNU Compiler
Collection (GCC) Internals},
for more discussion of @file{libgcc.a}.)
In most cases, you need @file{libgcc.a} even when you want to avoid
@@ -9450,7 +9450,7 @@
or @option{-nodefaultlibs} you should usually specify @option{-lgcc} as well.
This ensures that you have no unresolved references to internal GCC
library subroutines. (For example, @samp{__main}, used to ensure C++
-constructors will be called; @pxref{Collect2,,@code{collect2}, gccint,
+constructors will be called; @pxref{Collect2,,@code{collect2}, @value{fngccint},
GNU Compiler Collection (GCC) Internals}.)
@item -pie
@@ -19734,7 +19734,7 @@
@option{-B}, @option{-I} and @option{-L} (@pxref{Directory Options}). These
take precedence over places specified using environment variables, which
in turn take precedence over those specified by the configuration of GCC@.
-@xref{Driver,, Controlling the Compilation Driver @file{gcc}, gccint,
+@xref{Driver,, Controlling the Compilation Driver @file{gcc}, @value{fngccint},
GNU Compiler Collection (GCC) Internals}.
@table @env
@@ -19895,7 +19895,7 @@
A precompiled header file will be searched for when @code{#include} is
seen in the compilation. As it searches for the included file
-(@pxref{Search Path,,Search Path,cpp,The C Preprocessor}) the
+(@pxref{Search Path,,Search Path,@value{fncpp},The C Preprocessor}) the
compiler looks for a precompiled header in each directory just before it
looks for the include file in that directory. The name searched for is
the name specified in the @code{#include} with @samp{.gch} appended. If
Index: b/src/gcc/doc/extend.texi
===================================================================
--- a/src/gcc/doc/extend.texi
+++ b/src/gcc/doc/extend.texi
@@ -14874,7 +14874,7 @@
test for the GNU compiler the same way as for C programs: check for a
predefined macro @code{__GNUC__}. You can also use @code{__GNUG__} to
test specifically for GNU C++ (@pxref{Common Predefined Macros,,
-Predefined Macros,cpp,The GNU C Preprocessor}).
+Predefined Macros,@value{fncpp},The GNU C Preprocessor}).
@menu
* C++ Volatiles:: What constitutes an access to a volatile object.
Index: b/src/gcc/doc/standards.texi
===================================================================
--- a/src/gcc/doc/standards.texi
+++ b/src/gcc/doc/standards.texi
@@ -295,8 +295,8 @@
GNAT Reference Manual}, for information on standard
conformance and compatibility of the Ada compiler.
-@xref{Standards,,Standards, gfortran, The GNU Fortran Compiler}, for details
+@xref{Standards,,Standards, @value{fngfortran}, The GNU Fortran Compiler}, for details
of standards supported by GNU Fortran.
-@xref{Compatibility,,Compatibility with the Java Platform, gcj, GNU gcj},
+@xref{Compatibility,,Compatibility with the Java Platform, @value{fngcj}, GNU gcj},
for details of compatibility between @command{gcj} and the Java Platform.
Index: b/src/gcc/doc/libgcc.texi
===================================================================
--- a/src/gcc/doc/libgcc.texi
+++ b/src/gcc/doc/libgcc.texi
@@ -25,7 +25,7 @@
GCC will also generate calls to C library routines, such as
@code{memcpy} and @code{memset}, in some cases. The set of routines
that GCC may possibly use is documented in @ref{Other
-Builtins,,,gcc, Using the GNU Compiler Collection (GCC)}.
+Builtins,,,@value{fngcc}, Using the GNU Compiler Collection (GCC)}.
These routines take arguments and return values of a specific machine
mode, not a specific C type. @xref{Machine Modes}, for an explanation
Index: b/src/gcc/doc/gccint.texi
===================================================================
--- a/src/gcc/doc/gccint.texi
+++ b/src/gcc/doc/gccint.texi
@@ -51,7 +51,7 @@
@ifnottex
@dircategory Software development
@direntry
-* gccint: (gccint). Internals of the GNU Compiler Collection.
+* @value{fngccint}: (@value{fngccint}). Internals of the GNU Compiler Collection.
@end direntry
This file documents the internals of the GNU compilers.
@sp 1
@@ -83,7 +83,7 @@
@value{VERSION_PACKAGE}
@end ifset
version @value{version-GCC}. The use of the GNU compilers is documented in a
-separate manual. @xref{Top,, Introduction, gcc, Using the GNU
+separate manual. @xref{Top,, Introduction, @value{fngcc}, Using the GNU
Compiler Collection (GCC)}.
This manual is mainly a reference manual rather than a tutorial. It
Index: b/src/gcc/doc/cpp.texi
===================================================================
--- a/src/gcc/doc/cpp.texi
+++ b/src/gcc/doc/cpp.texi
@@ -53,7 +53,7 @@
@ifinfo
@dircategory Software development
@direntry
-* Cpp: (cpp). The GNU C preprocessor.
+* @value{fncpp}: (@value{fncpp}). The GNU C preprocessor.
@end direntry
@end ifinfo
Index: b/src/gcc/doc/passes.texi
===================================================================
--- a/src/gcc/doc/passes.texi
+++ b/src/gcc/doc/passes.texi
@@ -199,7 +199,7 @@
@item Mudflap declaration registration
If mudflap (@pxref{Optimize Options,,-fmudflap -fmudflapth
--fmudflapir,gcc,Using the GNU Compiler Collection (GCC)}) is
+-fmudflapir,@value{fngcc},Using the GNU Compiler Collection (GCC)}) is
enabled, we generate code to register some variable declarations with
the mudflap runtime. Specifically, the runtime tracks the lifetimes of
those variable declarations that have their addresses taken, or whose
Index: b/src/gcc/doc/gcc.texi
===================================================================
--- a/src/gcc/doc/gcc.texi
+++ b/src/gcc/doc/gcc.texi
@@ -65,8 +65,8 @@
@ifnottex
@dircategory Software development
@direntry
-* gcc: (gcc). The GNU Compiler Collection.
-* g++: (gcc). The GNU C++ compiler.
+* @value{fngcc}: (@value{fngcc}). The GNU Compiler Collection.
+* @value{fngxx}: (@value{fngcc}). The GNU C++ compiler.
@end direntry
This file documents the use of the GNU compilers.
@sp 1
@@ -126,7 +126,7 @@
The internals of the GNU compilers, including how to port them to new
targets and some information about how to write front ends for new
languages, are documented in a separate manual. @xref{Top,,
-Introduction, gccint, GNU Compiler Collection (GCC) Internals}.
+Introduction, @value{fngccint}, GNU Compiler Collection (GCC) Internals}.
@menu
* G++ and GCC:: You can compile C or C++ programs.
Index: b/src/gcc/doc/makefile.texi
===================================================================
--- a/src/gcc/doc/makefile.texi
+++ b/src/gcc/doc/makefile.texi
@@ -140,7 +140,7 @@
Builds a compiler with profiling feedback information. In this case,
the second and third stages are named @samp{profile} and @samp{feedback},
respectively. For more information, see
-@ref{Building,,Building with profile feedback,gccinstall,Installing GCC}.
+@ref{Building,,Building with profile feedback,@value{fngccinstall},Installing GCC}.
@item restrap
Restart a bootstrap, so that everything that was not built with
Index: b/src/gcc/doc/install.texi
===================================================================
--- a/src/gcc/doc/install.texi
+++ b/src/gcc/doc/install.texi
@@ -98,7 +98,7 @@
@end ifinfo
@dircategory Software development
@direntry
-* gccinstall: (gccinstall). Installing the GNU Compiler Collection.
+* @value{fngccinstall}: (@value{fngccinstall}). Installing the GNU Compiler Collection.
@end direntry
@c Part 3 Titlepage and Copyright
Index: b/src/gcc/doc/cppinternals.texi
===================================================================
--- a/src/gcc/doc/cppinternals.texi
+++ b/src/gcc/doc/cppinternals.texi
@@ -7,7 +7,7 @@
@ifinfo
@dircategory Software development
@direntry
-* Cpplib: (cppinternals). Cpplib internals.
+* @value{fncppint}: (@value{fncppint}). Cpplib internals.
@end direntry
@end ifinfo
Index: b/src/libgomp/libgomp.texi
===================================================================
--- a/src/libgomp/libgomp.texi
+++ b/src/libgomp/libgomp.texi
@@ -31,7 +31,7 @@
@ifinfo
@dircategory GNU Libraries
@direntry
-* libgomp: (libgomp). GNU OpenMP runtime library
+* @value{fnlibgomp}: (@value{fnlibgomp}). GNU OpenMP runtime library
@end direntry
This manual documents the GNU implementation of the OpenMP API for
Index: b/src/libgomp/Makefile.in
===================================================================
--- a/src/libgomp/Makefile.in
+++ b/src/libgomp/Makefile.in
@@ -345,7 +345,8 @@
# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
@BUILD_INFO_TRUE@STAMP_BUILD_INFO = stamp-build-info
-CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libgomp.info
+INFO_LIBGOMP_NAME = $(shell echo libgomp|sed '$(program_transform_name)')
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBGOMP_NAME).info
MAINTAINERCLEANFILES = $(srcdir)/libgomp.info
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
@@ -1092,15 +1093,16 @@
env.o: libgomp_f.h
all-local: $(STAMP_GENINSRC)
-
-stamp-geninsrc: libgomp.info
- cp -p $(top_builddir)/libgomp.info $(srcdir)/libgomp.info
+stamp-geninsrc: $(INFO_LIBGOMP_NAME).info
+ cp -p $(top_builddir)/$(INFO_LIBGOMP_NAME).info $(srcdir)/libgomp.info
@touch $@
-libgomp.info: $(STAMP_BUILD_INFO)
+libgomp.info: $(INFO_LIBGOMP_NAME).info
+ [ "$(INFO_LIBGOMP_NAME).info" = libgomp.info ] || cp $(INFO_LIBGOMP_NAME).info libgomp.info
+$(INFO_LIBGOMP_NAME).info: $(STAMP_BUILD_INFO)
stamp-build-info: libgomp.texi
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libgomp.info $(srcdir)/libgomp.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -D 'fnlibgomp $(INFO_LIBGOMP_NAME)' -I $(srcdir) -o $(INFO_LIBGOMP_NAME).info $(srcdir)/libgomp.texi
@touch $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
Index: b/src/libgomp/Makefile.am
===================================================================
--- a/src/libgomp/Makefile.am
+++ b/src/libgomp/Makefile.am
@@ -111,16 +111,19 @@
all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: libgomp.info
- cp -p $(top_builddir)/libgomp.info $(srcdir)/libgomp.info
+INFO_LIBGOMP_NAME = $(shell echo libgomp|sed '$(program_transform_name)')
+stamp-geninsrc: $(INFO_LIBGOMP_NAME).info
+ cp -p $(top_builddir)/$(INFO_LIBGOMP_NAME).info $(srcdir)/libgomp.info
@touch $@
-libgomp.info: $(STAMP_BUILD_INFO)
+libgomp.info: $(INFO_LIBGOMP_NAME).info
+ cp $(INFO_LIBGOMP_NAME).info libgomp.info
+$(INFO_LIBGOMP_NAME).info: $(STAMP_BUILD_INFO)
stamp-build-info: libgomp.texi
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libgomp.info $(srcdir)/libgomp.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -D 'fnlibgomp $(INFO_LIBGOMP_NAME)' -I $(srcdir) -o $(INFO_LIBGOMP_NAME).info $(srcdir)/libgomp.texi
@touch $@
-CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libgomp.info
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBGOMP_NAME).info
MAINTAINERCLEANFILES = $(srcdir)/libgomp.info
Index: b/src/libitm/libitm.texi
===================================================================
--- a/src/libitm/libitm.texi
+++ b/src/libitm/libitm.texi
@@ -20,7 +20,7 @@
@ifinfo
@dircategory GNU Libraries
@direntry
-* libitm: (libitm). GNU Transactional Memory Library
+* @value{fnlibitm}: (@value{fnlibitm}). GNU Transactional Memory Library
@end direntry
This manual documents the GNU Transactional Memory Library.
Index: b/src/libitm/Makefile.am
===================================================================
--- a/src/libitm/Makefile.am
+++ b/src/libitm/Makefile.am
@@ -105,14 +105,17 @@
all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: libitm.info
- cp -p $(top_builddir)/libitm.info $(srcdir)/libitm.info
+INFO_LIBITM_NAME = $(shell echo libitm|sed '$(program_transform_name)')
+stamp-geninsrc: $(INFO_LIBITM_NAME).info
+ cp -p $(top_builddir)/$(INFO_LIBITM_NAME).info $(srcdir)/libitm.info
@touch $@
-libitm.info: $(STAMP_BUILD_INFO)
+libitm.info: $(INFO_LIBITM_NAME).info
+ cp $(INFO_LIBITM_NAME).info libitm.info
+$(INFO_LIBITM_NAME).info: $(STAMP_BUILD_INFO)
stamp-build-info: libitm.texi
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libitm.info $(srcdir)/libitm.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -D 'fnlibitm $(INFO_LIBITM_NAME)'-o $(INFO_LIBITM_NAME).info $(srcdir)/libitm.texi
@touch $@
Index: b/src/libitm/Makefile.in
===================================================================
--- a/src/libitm/Makefile.in
+++ b/src/libitm/Makefile.in
@@ -1055,14 +1055,17 @@
all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: libitm.info
- cp -p $(top_builddir)/libitm.info $(srcdir)/libitm.info
+INFO_LIBITM_NAME = $(shell echo libitm|sed '$(program_transform_name)')
+stamp-geninsrc: $(INFO_LIBITM_NAME).info
+ cp -p $(top_builddir)/$(INFO_LIBITM_NAME).info $(srcdir)/libitm.info
@touch $@
-libitm.info: $(STAMP_BUILD_INFO)
+libitm.info: $(INFO_LIBITM_NAME).info
+ cp $(INFO_LIBITM_NAME).info libitm.info
+$(INFO_LIBITM_NAME).info: $(STAMP_BUILD_INFO)
stamp-build-info: libitm.texi
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libitm.info $(srcdir)/libitm.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -D 'fnlibitm $(INFO_LIBITM_NAME)' -o $(INFO_LIBITM_NAME).info $(srcdir)/libitm.texi
@touch $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
Index: b/src/gcc/go/Make-lang.in
===================================================================
--- a/src/gcc/go/Make-lang.in
+++ b/src/gcc/go/Make-lang.in
@@ -88,10 +88,11 @@
$(gcc_docdir)/include/gcc-common.texi \
gcc-vers.texi
-doc/gccgo.info: $(GO_TEXI_FILES)
+INFO_GCCGO_NAME = $(shell echo gccgo|sed '$(program_transform_name)')
+doc/$(INFO_GCCGO_NAME).info: $(GO_TEXI_FILES)
if test "x$(BUILD_INFO)" = xinfo; then \
- rm -f doc/gccgo.info*; \
- $(MAKEINFO) $(MAKEINFOFLAGS) -I $(gcc_docdir) \
+ rm -f doc/$(INFO_GCCGO_NAME).info*; \
+ $(MAKEINFO) $(MAKEINFOFLAGS) $(MAKEINFODEFS) -I $(gcc_docdir) \
-I $(gcc_docdir)/include -o $@ $<; \
else true; fi
@@ -117,7 +118,7 @@
go.all.cross: gccgo-cross$(exeext)
go.start.encap: gccgo$(exeext)
go.rest.encap:
-go.info: doc/gccgo.info
+go.info: doc/$(INFO_GCCGO_NAME).info
go.dvi: doc/gccgo.dvi
go.pdf: doc/gccgo.pdf
go.html: $(build_htmldir)/go/index.html
@@ -156,7 +157,7 @@
go.install-plugin:
-go.install-info: $(DESTDIR)$(infodir)/gccgo.info
+go.install-info: $(DESTDIR)$(infodir)/$(INFO_GCCGO_NAME).info
go.install-pdf: doc/gccgo.pdf
@$(NORMAL_INSTALL)
@@ -196,7 +197,7 @@
rm -rf $(DESTDIR)$(bindir)/$(GCCGO_INSTALL_NAME)$(exeext)
rm -rf $(DESTDIR)$(man1dir)/$(GCCGO_INSTALL_NAME)$(man1ext)
rm -rf $(DESTDIR)$(bindir)/$(GCCGO_TARGET_INSTALL_NAME)$(exeext)
- rm -rf $(DESTDIR)$(infodir)/gccgo.info*
+ rm -rf $(DESTDIR)$(infodir)/$(INFO_GCCGO_NAME).info*
# Clean hooks.
Index: b/src/gcc/go/gccgo.texi
===================================================================
--- a/src/gcc/go/gccgo.texi
+++ b/src/gcc/go/gccgo.texi
@@ -50,7 +50,7 @@
@format
@dircategory Software development
@direntry
-* Gccgo: (gccgo). A GCC-based compiler for the Go language
+* @value{fngccgo}: (@value{fngccgo}). A GCC-based compiler for the Go language
@end direntry
@end format
@@ -123,7 +123,7 @@
The @command{gccgo} command is a frontend to @command{gcc} and
supports many of the same options. @xref{Option Summary, , Option
-Summary, gcc, Using the GNU Compiler Collection (GCC)}. This manual
+Summary, @value{fngcc}, Using the GNU Compiler Collection (GCC)}. This manual
only documents the options specific to @command{gccgo}.
The @command{gccgo} command may be used to compile Go source code into
Index: b/src/libquadmath/libquadmath.texi
===================================================================
--- a/src/libquadmath/libquadmath.texi
+++ b/src/libquadmath/libquadmath.texi
@@ -25,7 +25,7 @@
@ifinfo
@dircategory GNU Libraries
@direntry
-* libquadmath: (libquadmath). GCC Quad-Precision Math Library
+* @value{fnlibquadmath}: (@value{fnlibquadmath}). GCC Quad-Precision Math Library
@end direntry
This manual documents the GCC Quad-Precision Math Library API.
Index: b/src/libquadmath/Makefile.am
===================================================================
--- a/src/libquadmath/Makefile.am
+++ b/src/libquadmath/Makefile.am
@@ -129,22 +129,24 @@
all-local: $(STAMP_GENINSRC)
-stamp-geninsrc: libquadmath.info
- cp -p $(top_builddir)/libquadmath.info $(srcdir)/libquadmath.info
+INFO_LIBQMATH_NAME = $(shell echo libquadmath|sed '$(program_transform_name)')
+
+stamp-geninsrc: $(INFO_LIBQMATH_NAME).info
+ cp -p $(top_builddir)/$(INFO_LIBQMATH_NAME).info $(srcdir)/libquadmath.info
@touch $@
stamp-build-info: libquadmath.texi $(libquadmath_TEXINFOS)
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libquadmath.info $(srcdir)/libquadmath.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o $(INFO_LIBQMATH_NAME).info $(srcdir)/libquadmath.texi
@touch $@
-CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libquadmath.info
-MAINTAINERCLEANFILES = $(srcdir)/libquadmath.info
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBQMATH_NAME).info
+MAINTAINERCLEANFILES = $(srcdir)/$(INFO_LIBQMATH_NAME).info
endif BUILD_LIBQUADMATH
# Unconditionally override this target, so that automake's definition
# does not wrongly interfere.
-libquadmath.info: $(STAMP_BUILD_INFO)
+$(INFO_LIBQMATH_NAME).info: $(STAMP_BUILD_INFO)
# Automake Documentation:
Index: b/src/libquadmath/Makefile.in
===================================================================
--- a/src/libquadmath/Makefile.in
+++ b/src/libquadmath/Makefile.in
@@ -164,7 +164,8 @@
MULTISUBDIR =
MULTIDO = true
MULTICLEAN = true
-INFO_DEPS = libquadmath.info
+INFO_LIBQMATH_NAME = $(shell echo libquadmath|sed '$(program_transform_name)')
+INFO_DEPS = $(INFO_LIBQMATH_NAME).info
am__TEXINFO_TEX_DIR = $(srcdir)/../gcc/doc/include
DVIS = libquadmath.dvi
PDFS = libquadmath.pdf
@@ -397,8 +398,8 @@
# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
@BUILD_INFO_TRUE@@BUILD_LIBQUADMATH_TRUE@STAMP_BUILD_INFO = stamp-build-info
-@BUILD_LIBQUADMATH_TRUE@CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libquadmath.info
-@BUILD_LIBQUADMATH_TRUE@MAINTAINERCLEANFILES = $(srcdir)/libquadmath.info
+@BUILD_LIBQUADMATH_TRUE@CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) $(INFO_LIBQMATH_NAME).info
+@BUILD_LIBQUADMATH_TRUE@MAINTAINERCLEANFILES = $(srcdir)/$(INFO_LIBQMATH_NAME).info
# Automake Documentation:
# If your package has Texinfo files in many directories, you can use the
@@ -1412,17 +1413,17 @@
@BUILD_LIBQUADMATH_TRUE@all-local: $(STAMP_GENINSRC)
-@BUILD_LIBQUADMATH_TRUE@stamp-geninsrc: libquadmath.info
-@BUILD_LIBQUADMATH_TRUE@ cp -p $(top_builddir)/libquadmath.info $(srcdir)/libquadmath.info
+@BUILD_LIBQUADMATH_TRUE@stamp-geninsrc: $(INFO_LIBQMATH_NAME).info
+@BUILD_LIBQUADMATH_TRUE@ cp -p $(top_builddir)/$(INFO_LIBQMATH_NAME).info $(srcdir)/$(INFO_LIBQMATH_NAME).info
@BUILD_LIBQUADMATH_TRUE@ @touch $@
@BUILD_LIBQUADMATH_TRUE@stamp-build-info: libquadmath.texi $(libquadmath_TEXINFOS)
-@BUILD_LIBQUADMATH_TRUE@ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libquadmath.info $(srcdir)/libquadmath.texi
+@BUILD_LIBQUADMATH_TRUE@ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o $(INFO_LIBQMATH_NAME).info $(srcdir)/libquadmath.texi
@BUILD_LIBQUADMATH_TRUE@ @touch $@
# Unconditionally override this target, so that automake's definition
# does not wrongly interfere.
-libquadmath.info: $(STAMP_BUILD_INFO)
+$(INFO_LIBQMATH_NAME).info: $(STAMP_BUILD_INFO)
libquadmath-vers.texi:
echo "@set BUGURL $(REPORT_BUGS_TEXI)" > $@
|