/usr/src/linux-source-4.4.0/debian/tests/rebuild is in linux-source-4.4.0 4.4.0-47.68.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 | #!/bin/sh
# If we are triggering for just linux or linux-meta we know we have
# just built the kernel and there is no point in repeating that
# build, it just wastes time. (LP: #1498862)
build_needed=0
for trigger in ${ADT_TEST_TRIGGERS:-force}
do
case "$trigger" in
linux/*|linux-lts-*/*|linux-meta*/*) ;;
*) build_needed=1 ;;
esac
done
if [ "$build_needed" -eq 0 ]; then
echo "rebuild: short circuiting build for '${ADT_TEST_TRIGGERS}'"
exit 0
fi
set -e
dpkg-buildpackage -rfakeroot -us -uc -b
|